summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-17 08:57:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-17 08:57:26 +0200
commit51312095d74728e7e953fee349bd38e11aae0346 (patch)
tree0f2aa45bf5b14ac0cc652006d8e5a36c1a9c9440 /dev-ros/tf2_tools/tf2_tools-0.6.3.ebuild
parentdev-ros/tf2_sensor_msgs: Bump to 0.6.3. (diff)
downloadgentoo-51312095d74728e7e953fee349bd38e11aae0346.tar.gz
gentoo-51312095d74728e7e953fee349bd38e11aae0346.tar.bz2
gentoo-51312095d74728e7e953fee349bd38e11aae0346.zip
dev-ros/tf2_tools: Bump to 0.6.3.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-ros/tf2_tools/tf2_tools-0.6.3.ebuild')
-rw-r--r--dev-ros/tf2_tools/tf2_tools-0.6.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/tf2_tools/tf2_tools-0.6.3.ebuild b/dev-ros/tf2_tools/tf2_tools-0.6.3.ebuild
new file mode 100644
index 000000000000..007bd064fc2d
--- /dev/null
+++ b/dev-ros/tf2_tools/tf2_tools-0.6.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 tools"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"