summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-25 20:21:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-25 20:21:43 +0200
commit4d893616106d03558c8f403911e33b42ef3b731d (patch)
treebf2215482e0bbab0a8498349ddce17d05615b067 /dev-ros/tf
parentdev-ros/tf: Remove old (diff)
downloadgentoo-4d893616106d03558c8f403911e33b42ef3b731d.tar.gz
gentoo-4d893616106d03558c8f403911e33b42ef3b731d.tar.bz2
gentoo-4d893616106d03558c8f403911e33b42ef3b731d.zip
dev-ros/tf: upstream fix for boost 1.70.0
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf')
-rw-r--r--dev-ros/tf/files/boost.patch28
-rw-r--r--dev-ros/tf/tf-1.12.0.ebuild3
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-ros/tf/files/boost.patch b/dev-ros/tf/files/boost.patch
new file mode 100644
index 000000000000..dd926cf05848
--- /dev/null
+++ b/dev-ros/tf/files/boost.patch
@@ -0,0 +1,28 @@
+From 2eed72cb7b63fc4ee98af695c625d9a741a09897 Mon Sep 17 00:00:00 2001
+From: Maarten de Vries <maarten@de-vri.es>
+Date: Thu, 17 Jan 2019 21:40:28 +0100
+Subject: [PATCH] Remove `signals` from find_package(Boost COMPONENTS ...)
+
+tf is using signals2, which is not the same library as signals.
+Additionally, signals2 has always been header only, and header only
+libraries must not be listed in find_package.
+
+Boost 1.69 removed the old signals library entirely, so the otherwise
+useless `COMPONENTS signals` actually breaks the build.
+---
+ tf/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
+index 04dcb4e8..b469f658 100644
+--- a/tf/CMakeLists.txt
++++ b/tf/CMakeLists.txt
+@@ -15,7 +15,7 @@ find_package(catkin REQUIRED COMPONENTS
+ std_msgs
+ tf2_ros
+ )
+-find_package(Boost REQUIRED COMPONENTS thread signals system)
++find_package(Boost REQUIRED COMPONENTS thread system)
+
+ catkin_python_setup()
+
diff --git a/dev-ros/tf/tf-1.12.0.ebuild b/dev-ros/tf/tf-1.12.0.ebuild
index d129d24ee28a..201cf57ee6b6 100644
--- a/dev-ros/tf/tf-1.12.0.ebuild
+++ b/dev-ros/tf/tf-1.12.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -36,3 +36,4 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
dev-python/nose[${PYTHON_USEDEP}]
)"
+PATCHES=( "${FILESDIR}/boost.patch" )