summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 19:59:17 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:51 +0100
commit4c930875ccb6d037492a5933ac350500145eced1 (patch)
tree611ede16dda1fa486c9f3d4f194ea5e41573c1a4 /dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild
parentdev-ros/tf2: fix build with ocnsole bridge 0.4 (diff)
downloadgentoo-4c930875ccb6d037492a5933ac350500145eced1.tar.gz
gentoo-4c930875ccb6d037492a5933ac350500145eced1.tar.bz2
gentoo-4c930875ccb6d037492a5933ac350500145eced1.zip
dev-ros/theora_image_transport: add missing ocnsole bridge dep
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild')
-rw-r--r--dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild b/dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild
new file mode 100644
index 000000000000..a13838696800
--- /dev/null
+++ b/dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending an image stream encoded with the Theora codec"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ media-libs/opencv
+ dev-ros/rosbag
+ dev-ros/pluginlib
+ media-libs/libogg
+ media-libs/libtheora[encode]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"