summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-26 09:08:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-26 11:18:30 +0200
commit291d58be3f46b4c15ba54f5e53a189676e3b73a1 (patch)
tree0603b8ffe151a0f869ef410674b3fd3c4848cb76 /dev-ros/urdf/urdf-1.12.3-r1.ebuild
parentdev-ros/urdf_parser_plugin: add patch to fix urdfdom 1 support. (diff)
downloadgentoo-291d58be3f46b4c15ba54f5e53a189676e3b73a1.tar.gz
gentoo-291d58be3f46b4c15ba54f5e53a189676e3b73a1.tar.bz2
gentoo-291d58be3f46b4c15ba54f5e53a189676e3b73a1.zip
dev-ros/urdf: fix build with urdfdom 1, add := dep on it.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/urdf/urdf-1.12.3-r1.ebuild')
-rw-r--r--dev-ros/urdf/urdf-1.12.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/urdf/urdf-1.12.3-r1.ebuild b/dev-ros/urdf/urdf-1.12.3-r1.ebuild
new file mode 100644
index 000000000000..eb2263d99d4d
--- /dev/null
+++ b/dev-ros/urdf/urdf-1.12.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin flag-o-matic
+
+DESCRIPTION="C++ parser for the Unified Robot Description Format (URDF)"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ >=dev-libs/urdfdom-1
+ dev-libs/urdfdom_headers
+ >=dev-ros/urdf_parser_plugin-1.12.3-r1
+ dev-ros/pluginlib
+ dev-ros/rosconsole_bridge
+ dev-ros/roscpp
+ dev-libs/tinyxml
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/urdfdom1.patch" )
+
+src_configure() {
+ append-cxxflags -std=c++11
+ ros-catkin_src_configure
+}