summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 18:08:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 18:15:57 +0200
commit3a38425ec3e6c6e1679fb135fa100cc738fb1eff (patch)
tree172fb56f333c3956e3fe119b8e71ee341642b283 /dev-ros
parentdev-ros/rosserial_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-3a38425ec3e6c6e1679fb135fa100cc738fb1eff.tar.gz
gentoo-3a38425ec3e6c6e1679fb135fa100cc738fb1eff.tar.bz2
gentoo-3a38425ec3e6c6e1679fb135fa100cc738fb1eff.zip
dev-ros/rosserial_python: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosserial_python/Manifest1
-rw-r--r--dev-ros/rosserial_python/metadata.xml5
-rw-r--r--dev-ros/rosserial_python/rosserial_python-0.7.1.ebuild24
-rw-r--r--dev-ros/rosserial_python/rosserial_python-9999.ebuild24
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/rosserial_python/Manifest b/dev-ros/rosserial_python/Manifest
new file mode 100644
index 000000000000..2af16836775c
--- /dev/null
+++ b/dev-ros/rosserial_python/Manifest
@@ -0,0 +1 @@
+DIST rosserial-0.7.1.tar.gz 102204 SHA256 203aeb4b1440da89f8e571372766f099d5d950901f0fa6991cc3b780aeca3331 SHA512 f63cdc674e2510e8d2990894fe21fcce7760cef18a7ce42951a07898d089a185c137d6643ff062a5bb4dfd2da0bd1571c077811ea67e8aee84bc2ad66d3160c5 WHIRLPOOL 8fddee9f232fff9d463855649c16fb01b3c85e8576481b7ca90fd22b00d95ca243b28d59df82d51643354f8219a8c7cad429aaa4b8822fe07cf3be54cdf0dfc7
diff --git a/dev-ros/rosserial_python/metadata.xml b/dev-ros/rosserial_python/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosserial_python/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosserial_python/rosserial_python-0.7.1.ebuild b/dev-ros/rosserial_python/rosserial_python-0.7.1.ebuild
new file mode 100644
index 000000000000..21d484d242b5
--- /dev/null
+++ b/dev-ros/rosserial_python/rosserial_python-0.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A Python-based implementation of the ROS serial protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosserial_python/rosserial_python-9999.ebuild b/dev-ros/rosserial_python/rosserial_python-9999.ebuild
new file mode 100644
index 000000000000..21d484d242b5
--- /dev/null
+++ b/dev-ros/rosserial_python/rosserial_python-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A Python-based implementation of the ROS serial protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"