summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-01 13:42:44 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-01 13:53:50 +0100
commit426190f78cbdabcfbec017ce9b156e435579286f (patch)
tree121fbaacf45b600e769a99b48c0539c45aecf8e5 /dev-ros
parentdev-ros/rosbag_storage: Bump to 1.12.6. (diff)
downloadgentoo-426190f78cbdabcfbec017ce9b156e435579286f.tar.gz
gentoo-426190f78cbdabcfbec017ce9b156e435579286f.tar.bz2
gentoo-426190f78cbdabcfbec017ce9b156e435579286f.zip
dev-ros/rosconsole: Bump to 1.12.6.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosconsole/Manifest1
-rw-r--r--dev-ros/rosconsole/rosconsole-1.12.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/Manifest b/dev-ros/rosconsole/Manifest
index 19393e5cdbd2..fad38b8610f8 100644
--- a/dev-ros/rosconsole/Manifest
+++ b/dev-ros/rosconsole/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.12.5.tar.gz 966478 SHA256 a53039f5106133b67689ba579e29c9045e3b1468713019cf72b848ce979b6964 SHA512 0d97eac0b0cf200a1e217597176d55c82249e2e7b9f3c4706dce84068a65c6642e099fb16c69d33b62d6c780d2c2775b7330fb497bc936f9d4bc73a2b5ba12ca WHIRLPOOL 3f1c8239ef146a0915b8f2c183c68eda094f480fa099846c6b152325bd1e8574114ecbb4a5bcd609bf1323f29767dc8110e175c79b07183cc8ff9e51f9a62b19
+DIST ros_comm-1.12.6.tar.gz 967763 SHA256 8585d952b1168d2011949b38c68160180b1f3ee1648a506bcb5989f9807335ca SHA512 1987c6362ae0c7c019a226223c73a7aefdc14a3fc66469ab6cdf9c41e9efdf4d7b7d4932af2a52f2082d716342a307b2e415c0ab45f77dfd9a7c1e4274deab5c WHIRLPOOL a719bb81da6b1b7e2f253d3bf6c8db8339333b4fa7f89a18d0fa734e9ff1700e1dac7b537f154015b4ada7455a6673c1715a89e2fdd3da9bbbb70081fc2943cd
diff --git a/dev-ros/rosconsole/rosconsole-1.12.6.ebuild b/dev-ros/rosconsole/rosconsole-1.12.6.ebuild
new file mode 100644
index 000000000000..39a48ae9c7ec
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.12.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}