summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 17:34:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 17:34:05 +0200
commit620a2a96ea7a45aa4a3ba239b4d6c6cab81e9d14 (patch)
tree0ab51e3ab9e59b2d2c3ca33a5894ed9ae5102ab7 /dev-ros
parentros-meta/rosbridge_suite: Initial import. Ebuild by me. (diff)
downloadgentoo-620a2a96ea7a45aa4a3ba239b4d6c6cab81e9d14.tar.gz
gentoo-620a2a96ea7a45aa4a3ba239b4d6c6cab81e9d14.tar.bz2
gentoo-620a2a96ea7a45aa4a3ba239b4d6c6cab81e9d14.zip
dev-ros/octomap_ros: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/octomap_ros/Manifest1
-rw-r--r--dev-ros/octomap_ros/metadata.xml5
-rw-r--r--dev-ros/octomap_ros/octomap_ros-0.4.0.ebuild22
-rw-r--r--dev-ros/octomap_ros/octomap_ros-9999.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-ros/octomap_ros/Manifest b/dev-ros/octomap_ros/Manifest
new file mode 100644
index 000000000000..6483a2146c45
--- /dev/null
+++ b/dev-ros/octomap_ros/Manifest
@@ -0,0 +1 @@
+DIST octomap_ros-0.4.0.tar.gz 5076 SHA256 6f4f90bbfe88c8314a406cfe70f0c4388d4d2d85a461d90911b2e6bf738ed153 SHA512 41910879d042dcbd969544e89fe40c1da8be75118ef1b813e3cb0319b83529a9c759fe99ed430b275d10d5df987bed7e2b4d7300ed561d159b6007de306bc8ce WHIRLPOOL 0840264e55bbcf9298e4d18ed0d39e8bfb7bbde7b42998ecdb28fa4b26e8184caa762747896a9e0da9f7028691836c508d22f74a61a8a20c7b562e2ec34892c1
diff --git a/dev-ros/octomap_ros/metadata.xml b/dev-ros/octomap_ros/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/octomap_ros/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/octomap_ros/octomap_ros-0.4.0.ebuild b/dev-ros/octomap_ros/octomap_ros-0.4.0.ebuild
new file mode 100644
index 000000000000..36b7f89cdac5
--- /dev/null
+++ b/dev-ros/octomap_ros/octomap_ros-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/OctoMap/octomap_ros"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Conversion functions between ROS / PCL and OctoMap's native types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/pcl_ros
+ dev-ros/octomap_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/octomap_ros/octomap_ros-9999.ebuild b/dev-ros/octomap_ros/octomap_ros-9999.ebuild
new file mode 100644
index 000000000000..36b7f89cdac5
--- /dev/null
+++ b/dev-ros/octomap_ros/octomap_ros-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/OctoMap/octomap_ros"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Conversion functions between ROS / PCL and OctoMap's native types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/pcl_ros
+ dev-ros/octomap_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"