summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-29 16:26:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-29 18:01:01 +0200
commit728a25da6bdd7c4d4146492e12df148c884340fa (patch)
tree210cd8da6ee233611617f5202e720808f8ce4f37 /dev-ros
parentdev-ros/gazebo_plugins: Bump to 2.9.2. (diff)
downloadgentoo-728a25da6bdd7c4d4146492e12df148c884340fa.tar.gz
gentoo-728a25da6bdd7c4d4146492e12df148c884340fa.tar.bz2
gentoo-728a25da6bdd7c4d4146492e12df148c884340fa.zip
dev-ros/gazebo_ros: Bump to 2.9.2.
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/gazebo_ros/Manifest1
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.9.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/Manifest b/dev-ros/gazebo_ros/Manifest
index 2a5c0acc89ae..c4816a40bfc6 100644
--- a/dev-ros/gazebo_ros/Manifest
+++ b/dev-ros/gazebo_ros/Manifest
@@ -1 +1,2 @@
DIST gazebo_ros_pkgs-2.9.1.tar.gz 1861740 BLAKE2B 56569e73184c767abeea0ac6add8aa19bb70e66f3a41fe9fc5278e540759de945467372c7a0130acdb665924ab803defa22e148a36a624d08c39835dc110e208 SHA512 47510f97060d5434619948899b416a8136545b79cd112051543212abe8ce34a30c1f868c633a3f3288fd6c0ea775162daf2eea15ca539a352c9bdb55ee336b20
+DIST gazebo_ros_pkgs-2.9.2.tar.gz 1864333 BLAKE2B d8a777594624fe6ae38f1ae27ea49f9629a59f507ec5e8512f50dbf8ae551e6b171dd47eff308ab1badc4e07de7183fe512ff8179637169896f6cb1dbf3d50ba SHA512 38ca70b44a229d8ca87bf9cb2ed3e0eaf7855f5711a81891986a985b7ff4218cdd6c914c1d25352da47a3fb52a3df5638af36990264e5241d17bb43ae0fa6f0b
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.9.2.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.9.2.ebuild
new file mode 100644
index 000000000000..f617eb50bd9b
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer messages and services for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"