summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-05 15:57:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-06 18:17:29 +0200
commit73866d0060c005fba9de64d0a47f3258b66669a5 (patch)
treee67fdf458c002b100dfe624038094ad02beab9aa /dev-ros
parentros-meta/mavros: Bump to 0.19.0. (diff)
downloadgentoo-73866d0060c005fba9de64d0a47f3258b66669a5.tar.gz
gentoo-73866d0060c005fba9de64d0a47f3258b66669a5.tar.bz2
gentoo-73866d0060c005fba9de64d0a47f3258b66669a5.zip
dev-ros/mavros: bump to 0.19.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/mavros/Manifest1
-rw-r--r--dev-ros/mavros/mavros-0.19.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/mavros/Manifest b/dev-ros/mavros/Manifest
index 7ddea4f5d3cf..99894a1bb71d 100644
--- a/dev-ros/mavros/Manifest
+++ b/dev-ros/mavros/Manifest
@@ -1 +1,2 @@
DIST mavros-0.18.7.tar.gz 213566 SHA256 92e086072ac0641143b59d1dbda7ab54e5903d55001eaeceb34432efe3b07dcc SHA512 8ab17de7b9892d8eb7141d998460814d572d359b6ab5a3d2fe6a854506eedd784b936f9630a917b3de9ef5db7ac1375ff8374e816e9d0262f3d6b926b86f68ec WHIRLPOOL 92c1d7fe233433a68e08acfbaa6d996d3187279c2b1d806937bcf0bd5f564746e45cf1f7f1811afbb6b1095d98317b6cb321d85014ad3e679a470f89c0d4aee8
+DIST mavros-0.19.0.tar.gz 219739 SHA256 f1c434c15a658e4b7560d52f967a0e9d925c0609715d2bb781ae5df4bedd925c SHA512 87b1b77505d3606196d609a016bcb89b3831e982f8352a13f69f5c2580f46ac603edb2d3c2ce4df5cdd1424172145b88d2b35d149c2be507eb0f23039e7e45a7 WHIRLPOOL e5c1ba70e1fd6c22012a8a01d9da20252647a82ec79a778fc7319e5804812be85b85a5d676f1027fbfb6dfc340a251cdb38fb5846c570fc059bf54aef008a6f2
diff --git a/dev-ros/mavros/mavros-0.19.0.ebuild b/dev-ros/mavros/mavros-0.19.0.ebuild
new file mode 100644
index 000000000000..da09ea92fea7
--- /dev/null
+++ b/dev-ros/mavros/mavros-0.19.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink extendable communication node for ROS"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/angles
+ dev-ros/libmavconn
+ dev-ros/rosconsole_bridge
+ dev-libs/boost:=
+ dev-ros/eigen_conversions
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavros_msgs-${PV}[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavlink-gbp-release-2016.11.11
+"
+DEPEND="${RDEPEND}"