summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-05-07 11:53:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-05-07 12:00:21 +0200
commit75069faf158f2e23b008fc4058333a52df39dd03 (patch)
treece9581e9ad5dc9075447023c3895c33704d4c0ee /dev-ros
parentdev-ros/rosmake: Bump to 1.14.6. (diff)
downloadgentoo-75069faf158f2e23b008fc4058333a52df39dd03.tar.gz
gentoo-75069faf158f2e23b008fc4058333a52df39dd03.tar.bz2
gentoo-75069faf158f2e23b008fc4058333a52df39dd03.zip
dev-ros/rosunit: Bump to 1.14.6.
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosunit/Manifest1
-rw-r--r--dev-ros/rosunit/rosunit-1.14.6.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosunit/Manifest b/dev-ros/rosunit/Manifest
index f8abd3c7fedf..ff4974fa94ba 100644
--- a/dev-ros/rosunit/Manifest
+++ b/dev-ros/rosunit/Manifest
@@ -3,3 +3,4 @@ DIST ros-1.14.1.tar.gz 167768 BLAKE2B 1d4ec3b2af505be4995ade962c8d7c8f165af40b69
DIST ros-1.14.2.tar.gz 167882 BLAKE2B 7aadc3d06b02b58067a805613dd87cab3a97a0d0f2ddd79c496a63d75abba3444e2b624ff17308db910d9e1beca43b67d897f1358fbe4d9484a560da2de987f8 SHA512 9d848140bc694f0f2b86f8c9ef67e0279c5f05a73abe43f54aedb7439c7810346d136445c7195310e5f00e0a0cdfbbf6cbb004e7ab0b1427811ec8b0a73933d5
DIST ros-1.14.3.tar.gz 166640 BLAKE2B 191f3455853ff070d7a53352b801adad58b2c32d683994c96ce6dcab297a4032dc1ac313f9be7547596440a4179ecd38f743c4b02cac8326872f450a59847bc1 SHA512 60b8a38765539a7598c9725de56ef859022875c3b2c50636bf0a79c7aca653d0efd487ad60639362c90a6d983d9e76a8fbf565a91d53da21cfb4fa95bf7ac786
DIST ros-1.14.4.tar.gz 166818 BLAKE2B cbe56006ba8e318a9b94e67ea2035b209d206b6f2783c9a923c227ad92f932879a14d08cb076168159a5eb190e82e3375a70474ffae6305887086f8c0aaf3599 SHA512 ba6a25b5aae6786a9033ada747293b10e5aab2cf55b68fd8f40090f13dac7615b332993201795d6dac729dce0dcc4438df22f520bdca16c5ed127ad33eca1e9c
+DIST ros-1.14.6.tar.gz 174375 BLAKE2B bb3c7b60c1d89ff2b219802c60fbb39ad54cb15250f6c17ef27f64a66e148bbf8da5b836ff38f0a83cf3e2fa3615ce298ef888c95607f6f33d8511a1bb04e6a5 SHA512 f30f33553aeae267b608b705b4e8b2502260ed47e3461c36da265318b5d78369a857e3fb67fc55f20f2dd9010bac6eda213bbe0442a142fbe223ebf34a48ea38
diff --git a/dev-ros/rosunit/rosunit-1.14.6.ebuild b/dev-ros/rosunit/rosunit-1.14.6.ebuild
new file mode 100644
index 000000000000..af7d4b220e08
--- /dev/null
+++ b/dev-ros/rosunit/rosunit-1.14.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit-testing package for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"