summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 03:48:11 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:18:24 +0100
commit8451a3df3f8c92383972a7448345f53932ab60de (patch)
treef00d2d5649b8751f01109b77d8661b16eae4a888 /dev-ros
parentdev-ros/qt_gui_cpp: move CMAKE_MAKEFILE_GENERATOR to pre-inherit (diff)
downloadgentoo-8451a3df3f8c92383972a7448345f53932ab60de.tar.gz
gentoo-8451a3df3f8c92383972a7448345f53932ab60de.tar.bz2
gentoo-8451a3df3f8c92383972a7448345f53932ab60de.zip
dev-ros/roslint: move CMAKE_MAKEFILE_GENERATOR to pre-inherit
Marked as @PRE_INHERIT within cmake.eclass because it manipulates dependencies in global scope. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/roslint/roslint-0.12.0.ebuild4
-rw-r--r--dev-ros/roslint/roslint-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-ros/roslint/roslint-0.12.0.ebuild b/dev-ros/roslint/roslint-0.12.0.ebuild
index 58b60db84260..eff6b00931fb 100644
--- a/dev-ros/roslint/roslint-0.12.0.ebuild
+++ b/dev-ros/roslint/roslint-0.12.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ROS_REPO_URI="https://github.com/ros/roslint"
KEYWORDS="~amd64 ~arm"
+CMAKE_MAKEFILE_GENERATOR="emake" # https://bugs.gentoo.org/738584
inherit ros-catkin
DESCRIPTION="Static checking of Python or C++ source code for errors and standards compliance"
@@ -14,4 +15,3 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
-CMAKE_MAKEFILE_GENERATOR="emake" # https://bugs.gentoo.org/738584
diff --git a/dev-ros/roslint/roslint-9999.ebuild b/dev-ros/roslint/roslint-9999.ebuild
index 58b60db84260..eff6b00931fb 100644
--- a/dev-ros/roslint/roslint-9999.ebuild
+++ b/dev-ros/roslint/roslint-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ROS_REPO_URI="https://github.com/ros/roslint"
KEYWORDS="~amd64 ~arm"
+CMAKE_MAKEFILE_GENERATOR="emake" # https://bugs.gentoo.org/738584
inherit ros-catkin
DESCRIPTION="Static checking of Python or C++ source code for errors and standards compliance"
@@ -14,4 +15,3 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
-CMAKE_MAKEFILE_GENERATOR="emake" # https://bugs.gentoo.org/738584