summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 07:39:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:05 +0200
commit8d403f54648b67e9f2ed86cb324228336de2385d (patch)
treef780f87480ff9058c623c2f7d1f9a3b6e169b16a /dev-ros
parentdev-ros/rqt_graph: remove old (diff)
downloadgentoo-8d403f54648b67e9f2ed86cb324228336de2385d.tar.gz
gentoo-8d403f54648b67e9f2ed86cb324228336de2385d.tar.bz2
gentoo-8d403f54648b67e9f2ed86cb324228336de2385d.zip
dev-ros/rqt_graph: bump to 0.4.8 and update to split repo
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rqt_graph/Manifest1
-rw-r--r--dev-ros/rqt_graph/metadata.xml2
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild30
-rw-r--r--dev-ros/rqt_graph/rqt_graph-9999.ebuild5
4 files changed, 34 insertions, 4 deletions
diff --git a/dev-ros/rqt_graph/Manifest b/dev-ros/rqt_graph/Manifest
index 7bb8c4d74093..a3f182b5d600 100644
--- a/dev-ros/rqt_graph/Manifest
+++ b/dev-ros/rqt_graph/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_graph-0.4.8.tar.gz 15785 SHA256 db2ec3857a9576a4e7ed2b97b64aa57ae41e9d89901b5e2d504fdfc117678f37 SHA512 9e1cf0a43fef0a2dd245139abda9d08da5aeb6c78177247db8e25d8fa97a3394bf4617a4b0ad1f59af5c08cb56c1f02852b16a7dc2ee5fe11e05b2e515501314 WHIRLPOOL c73244a078ec952c06e34d63db5bb587d06a0ef732b8e17f86a49585d8e12fd02f0ba9aa58b5cc8334f417e8663b35182951fa4dd755d15fd9b2ad01b2b42ed8
diff --git a/dev-ros/rqt_graph/metadata.xml b/dev-ros/rqt_graph/metadata.xml
index cb473d142b8e..c709b25c73d5 100644
--- a/dev-ros/rqt_graph/metadata.xml
+++ b/dev-ros/rqt_graph/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_graph</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild b/dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild
new file mode 100644
index 000000000000..1f2bff4c39fc
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.4.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_graph/rqt_graph-9999.ebuild b/dev-ros/rqt_graph/rqt_graph-9999.ebuild
index b38ac4eb4d9c..1f2bff4c39fc 100644
--- a/dev-ros/rqt_graph/rqt_graph-9999.ebuild
+++ b/dev-ros/rqt_graph/rqt_graph-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin