summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-27 14:23:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-27 14:23:29 +0200
commitaca4053c2ab810371595d844aa0cf8c6a7710eb7 (patch)
tree7fc05b6794e07ff95656a4251849d956f3278e09 /dev-ros
parentdev-ros/resource_retriever: remove old (diff)
downloadgentoo-aca4053c2ab810371595d844aa0cf8c6a7710eb7.tar.gz
gentoo-aca4053c2ab810371595d844aa0cf8c6a7710eb7.tar.bz2
gentoo-aca4053c2ab810371595d844aa0cf8c6a7710eb7.zip
dev-ros/resource_retriever: fix build with curl 7.50.0, bug #589424
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/resource_retriever/files/curl.patch14
-rw-r--r--dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild1
2 files changed, 15 insertions, 0 deletions
diff --git a/dev-ros/resource_retriever/files/curl.patch b/dev-ros/resource_retriever/files/curl.patch
new file mode 100644
index 000000000000..4717cc601c5f
--- /dev/null
+++ b/dev-ros/resource_retriever/files/curl.patch
@@ -0,0 +1,14 @@
+Index: resource_retriever-1.12.2/include/resource_retriever/retriever.h
+===================================================================
+--- resource_retriever-1.12.2.orig/include/resource_retriever/retriever.h
++++ resource_retriever-1.12.2/include/resource_retriever/retriever.h
+@@ -32,8 +32,7 @@
+ #include <string>
+ #include <boost/shared_array.hpp>
+ #include <stdexcept>
+-
+-typedef void CURL;
++#include <curl/curl.h>
+
+ namespace resource_retriever
+ {
diff --git a/dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild b/dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild
index 0a3c5907b1e1..798c4034ecdd 100644
--- a/dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild
+++ b/dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild
@@ -22,3 +22,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/curl.patch" )