summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-02 15:55:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-05 11:52:17 +0200
commitaf00dfbe50647735ab17d743200213da486c7560 (patch)
treea0727aae5fc83d26261ce025c4d61a931ddef3e0 /dev-ros
parentros-meta/ros_comm: Bump to 1.15.10. (diff)
downloadgentoo-af00dfbe50647735ab17d743200213da486c7560.tar.gz
gentoo-af00dfbe50647735ab17d743200213da486c7560.tar.bz2
gentoo-af00dfbe50647735ab17d743200213da486c7560.zip
dev-ros/rosmsg: fix src_test
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.15.10.ebuild12
-rw-r--r--dev-ros/rosmsg/rosmsg-1.15.9.ebuild10
-rw-r--r--dev-ros/rosmsg/rosmsg-9999.ebuild14
3 files changed, 29 insertions, 7 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.15.10.ebuild b/dev-ros/rosmsg/rosmsg-1.15.10.ebuild
index 34327c1b7d48..d4be4db4044c 100644
--- a/dev-ros/rosmsg/rosmsg-1.15.10.ebuild
+++ b/dev-ros/rosmsg/rosmsg-1.15.10.ebuild
@@ -21,5 +21,15 @@ RDEPEND="
dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}] )
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}/../..:${EPREFIX}/usr/share/ros_packages/diagnostic_msgs:${EPREFIX}/usr/share/ros_packages/std_msgs:${EPREFIX}/usr/share/ros_packages/std_srvs"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/rosmsg/rosmsg-1.15.9.ebuild b/dev-ros/rosmsg/rosmsg-1.15.9.ebuild
index c750959458b6..a1986af34a32 100644
--- a/dev-ros/rosmsg/rosmsg-1.15.9.ebuild
+++ b/dev-ros/rosmsg/rosmsg-1.15.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,11 +21,13 @@ RDEPEND="
dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}] )
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
"
-PATCHES=( "${FILESDIR}/duplicates.patch" )
src_test() {
- export ROS_PACKAGE_PATH="${S}/../../:${ROS_PACKAGE_PATH}"
+ export ROS_PACKAGE_PATH="${S}:${EPREFIX}/usr/share/ros_packages/diagnostic_msgs"
ros-catkin_src_test
}
diff --git a/dev-ros/rosmsg/rosmsg-9999.ebuild b/dev-ros/rosmsg/rosmsg-9999.ebuild
index ba0d62bb080b..d4be4db4044c 100644
--- a/dev-ros/rosmsg/rosmsg-9999.ebuild
+++ b/dev-ros/rosmsg/rosmsg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,5 +21,15 @@ RDEPEND="
dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}] )
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}/../..:${EPREFIX}/usr/share/ros_packages/diagnostic_msgs:${EPREFIX}/usr/share/ros_packages/std_msgs:${EPREFIX}/usr/share/ros_packages/std_srvs"
+ ros-catkin_src_test
+}