summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-06 10:39:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-06 11:30:50 +0200
commitbb15b9a9f3d36268b08dddb42b17391619237886 (patch)
tree534a80bcb360f4347c35af3e2c41b9d3ec3e34ba /dev-ros
parentdev-ros/ament_lint: bump to 0.10.4 (diff)
downloadgentoo-bb15b9a9f3d36268b08dddb42b17391619237886.tar.gz
gentoo-bb15b9a9f3d36268b08dddb42b17391619237886.tar.bz2
gentoo-bb15b9a9f3d36268b08dddb42b17391619237886.zip
dev-ros/ament_copyright: bump to 0.10.4
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_copyright/Manifest1
-rw-r--r--dev-ros/ament_copyright/ament_copyright-0.10.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-ros/ament_copyright/Manifest b/dev-ros/ament_copyright/Manifest
index 7fd0dfc330ef..7ae1c97b2996 100644
--- a/dev-ros/ament_copyright/Manifest
+++ b/dev-ros/ament_copyright/Manifest
@@ -1,2 +1,3 @@
DIST ament_lint-0.10.0.tar.gz 219525 BLAKE2B 6ba7a32d0678e545c24b74ed187991140c34a363ad855e469f0e20f8a088b7cc939bbd187566233e099576e4c2b899d7d75edf311d3026234222078968be7ce6 SHA512 565413fa325317e6f00ce18051eb13556d1d50144d2c8f62368e5505455ef7f9fae3a69e8d723a3949e44b1f9e638741ae6d9b87687df81a661eb804365200f8
DIST ament_lint-0.10.1.tar.gz 221215 BLAKE2B 47ffa7dfd892b05f345ba962c7c08dcf1627c4653cc75e1a1d1cad28971974ef5ca9c09d3989b3fdbfacd7f94dace9651c44911cd7747f39c5c59083f0195443 SHA512 1dd996d86cfb7488bd6bf57510eb5b7531fe4fe21d25203a4801046ec719ba19afdb89eb7ba9d862317d2e041e7139fadde27d114614d96741a177e8ec2a2ba3
+DIST ament_lint-0.10.4.tar.gz 222285 BLAKE2B 81a15dc996bad0fe3fa461aa7067eba423550d94a04881a12c8a4b0732a4a0ddcc30ab6bef94f81cb236836d8de7959b53d5560d5fb6eb480f2fbd849bd02489 SHA512 cb99084622f598b17f1ffe55620c9c822867771f2603e673098f8943d95b7be188e25480d4e22bf7c2988e94d8b69f6f7fa3b60cd042213f6bd8c2ad2c5deaf3
diff --git a/dev-ros/ament_copyright/ament_copyright-0.10.4.ebuild b/dev-ros/ament_copyright/ament_copyright-0.10.4.ebuild
new file mode 100644
index 000000000000..e23e04234485
--- /dev/null
+++ b/dev-ros/ament_copyright/ament_copyright-0.10.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to check source files for copyright and license information."
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+ dev-ros/ament_lint
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}