summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-15 17:29:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-15 18:05:40 +0100
commitbed81ab3db88bf178435b8c343b164a22ce132bf (patch)
tree7819159057a9305da3c4454f89466f30eb4cd9c4 /dev-ros
parentdev-ros/ament_copyright: bump to 0.12.1 (diff)
downloadgentoo-bed81ab3db88bf178435b8c343b164a22ce132bf.tar.gz
gentoo-bed81ab3db88bf178435b8c343b164a22ce132bf.tar.bz2
gentoo-bed81ab3db88bf178435b8c343b164a22ce132bf.zip
dev-ros/ament_pep257: bump to 0.12.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_pep257/Manifest1
-rw-r--r--dev-ros/ament_pep257/ament_pep257-0.12.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/ament_pep257/Manifest b/dev-ros/ament_pep257/Manifest
index 99d511dac320..4e5ba15bbab6 100644
--- a/dev-ros/ament_pep257/Manifest
+++ b/dev-ros/ament_pep257/Manifest
@@ -1 +1,2 @@
DIST ament_lint-0.11.2.tar.gz 265435 BLAKE2B 09545bd029dc692e5393983a3fc9210600c4a6456635238b7038ff87799f9cfde9c2d3c7ceb4c01b71594ba7bd159e8b6b3c2370bdfcdbf3d6189a895b96292a SHA512 1a379f4fb0ead306a668aef2b9e390728d6d3901b75f43fac6ccc28681a8010e42b094237f3f1ab95ca304ba917c8fb5d5519ec0581cadb346e6eb05466e39f0
+DIST ament_lint-0.12.1.tar.gz 281555 BLAKE2B 1feabfc9e65b09970cb9d9706e9fbc3ca8b60d0592597a8a8666f3b272e71a09c28bf3f21926f0f3b96d93e61d3f8c99286b2b5658359116305bbaf449b40207 SHA512 34625c9ff0615c09dc5e918896af5f46480de735388e57c06c8d8f3267cd98c7e0314ddc99d8ba328dbfa949c51eb893121f6639689f3a803503c77164e56bcc
diff --git a/dev-ros/ament_pep257/ament_pep257-0.12.1.ebuild b/dev-ros/ament_pep257/ament_pep257-0.12.1.ebuild
new file mode 100644
index 000000000000..b1c410e3822a
--- /dev/null
+++ b/dev-ros/ament_pep257/ament_pep257-0.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Checks code against style conventions in PEP 8 and generate test result files"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-ros/ament_lint[${PYTHON_USEDEP}]
+ dev-python/pydocstyle[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest