summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-07 12:47:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-07 12:48:09 +0200
commitc7ecbb327a1586d4c6c5ca2e6e45b2efd049db8f (patch)
tree07fc077251cf7ec524e646c6a4f1950fee8b2c27 /dev-ros
parentwww-servers/uwsgi: version bump (diff)
downloadgentoo-c7ecbb327a1586d4c6c5ca2e6e45b2efd049db8f.tar.gz
gentoo-c7ecbb327a1586d4c6c5ca2e6e45b2efd049db8f.tar.bz2
gentoo-c7ecbb327a1586d4c6c5ca2e6e45b2efd049db8f.zip
dev-ros/filters: Backport upstream fix to build without rostest when tests are not enabled. Bug #562466.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/filters/files/rostest.patch27
-rw-r--r--dev-ros/filters/filters-1.7.4.ebuild2
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-ros/filters/files/rostest.patch b/dev-ros/filters/files/rostest.patch
new file mode 100644
index 000000000000..6a266fdef614
--- /dev/null
+++ b/dev-ros/filters/files/rostest.patch
@@ -0,0 +1,27 @@
+commit 5aef0d6619394df17bffe743071295ad041b5794
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date: Tue Feb 4 16:02:09 2014 +0100
+
+ make rostest in CMakeLists optional (ros/rosdistro#3010)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ccb54f9..97eea51 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,7 +5,7 @@ project(filters)
+ # Find dependencies
+ ##############################################################################
+
+-find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole rostest)
++find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole)
+ find_package(Boost COMPONENTS system filesystem thread REQUIRED)
+
+ include_directories(
+@@ -41,6 +41,7 @@ add_library(transfer_function src/transfer_function.cpp)
+ target_link_libraries(transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES})
+
+ if(CATKIN_ENABLE_TESTING)
++ find_package(rostest)
+ # Test median filter
+ add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
+ target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
diff --git a/dev-ros/filters/filters-1.7.4.ebuild b/dev-ros/filters/filters-1.7.4.ebuild
index 4b50ee0a0497..d718f2d4a9f9 100644
--- a/dev-ros/filters/filters-1.7.4.ebuild
+++ b/dev-ros/filters/filters-1.7.4.ebuild
@@ -18,4 +18,4 @@ RDEPEND="dev-ros/roscpp
dev-ros/pluginlib"
DEPEND="${RDEPEND}
test? ( dev-ros/rostest dev-cpp/gtest )"
-PATCHES=( "${FILESDIR}/tests.patch" )
+PATCHES=( "${FILESDIR}/tests.patch" "${FILESDIR}/rostest.patch" )