summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-02 09:52:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-02 09:52:47 +0100
commitd825b55d90afbb583a24de11d498d730d749a464 (patch)
tree5e79f494ed84f8a44051ba5620f1965fe002977d /dev-ros
parentdev-ros/urg_node: Initial import. Ebuild by me. (diff)
downloadgentoo-d825b55d90afbb583a24de11d498d730d749a464.tar.gz
gentoo-d825b55d90afbb583a24de11d498d730d749a464.tar.bz2
gentoo-d825b55d90afbb583a24de11d498d730d749a464.zip
dev-ros/depthimage_to_laserscan: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/depthimage_to_laserscan/Manifest1
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7.ebuild24
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild24
-rw-r--r--dev-ros/depthimage_to_laserscan/metadata.xml5
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/depthimage_to_laserscan/Manifest b/dev-ros/depthimage_to_laserscan/Manifest
new file mode 100644
index 000000000000..0b93ebbab68d
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/Manifest
@@ -0,0 +1 @@
+DIST depthimage_to_laserscan-1.0.7.tar.gz 12121 SHA256 3aa236f81cfd26e55718edfb50ef837a59b57169cb20a5b24f9a4e99602a09e8 SHA512 4da5fa446d574dbb44c2924dd760f160e527e68d7df119e5d9e74d85efd3473ee31845e8565b0d023d2cf22c945b3b5c56b12a04facd4e38dc3dd1235dad73e9 WHIRLPOOL a6c848acefa9ce95612167911d2f67afa0ae3e208559648939d4bcd7813a6ebd79e287dae46140c6b080a6b036cfff3bf2e70c494f248fd23d3f61d60fe825cd
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7.ebuild
new file mode 100644
index 000000000000..98afcc8f62b6
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
new file mode 100644
index 000000000000..98afcc8f62b6
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/depthimage_to_laserscan/metadata.xml b/dev-ros/depthimage_to_laserscan/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>