summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 07:37:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:04 +0200
commite57f3395bcfb8705125f5811e4ffca18df81b67a (patch)
treeb36c995897187d104c9a4f0688a939ee588f22a3 /dev-ros
parentdev-ros/rqt_dep: remove old (diff)
downloadgentoo-e57f3395bcfb8705125f5811e4ffca18df81b67a.tar.gz
gentoo-e57f3395bcfb8705125f5811e4ffca18df81b67a.tar.bz2
gentoo-e57f3395bcfb8705125f5811e4ffca18df81b67a.zip
dev-ros/rqt_dep: bump to 0.4.8 and update to separate repo
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rqt_dep/Manifest1
-rw-r--r--dev-ros/rqt_dep/metadata.xml2
-rw-r--r--dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild26
-rw-r--r--dev-ros/rqt_dep/rqt_dep-9999.ebuild5
4 files changed, 30 insertions, 4 deletions
diff --git a/dev-ros/rqt_dep/Manifest b/dev-ros/rqt_dep/Manifest
index 7bb8c4d74093..9427e1459f3d 100644
--- a/dev-ros/rqt_dep/Manifest
+++ b/dev-ros/rqt_dep/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_dep-0.4.8.tar.gz 12398 SHA256 cd0209a55fefb6148e282297dc88c67d93fb32e0e7bded361f5eec1a22f0b384 SHA512 b56f1b78ab80feeef3965586d5b67d5342113e9ec2ccc2964c255bcf06b311b112346d2fe48f4cf5c92c97c396917d915999c36b46279be98e3be30b0a4212dd WHIRLPOOL ebb2884867023793222978085fc724565744933bc32143b961d38613dc983be5b381095dfdecae0503569a7bcbda9fba140d494a9e75c66575e3478d7222d330
diff --git a/dev-ros/rqt_dep/metadata.xml b/dev-ros/rqt_dep/metadata.xml
index cb473d142b8e..19eeba0f3997 100644
--- a/dev-ros/rqt_dep/metadata.xml
+++ b/dev-ros/rqt_dep/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_dep</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild b/dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild
new file mode 100644
index 000000000000..da5568842166
--- /dev/null
+++ b/dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_dep"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS dependency graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/rqt_dep/rqt_dep-9999.ebuild b/dev-ros/rqt_dep/rqt_dep-9999.ebuild
index abcb4a2f33ad..da5568842166 100644
--- a/dev-ros/rqt_dep/rqt_dep-9999.ebuild
+++ b/dev-ros/rqt_dep/rqt_dep-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_dep"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin