summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-13 09:08:20 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-13 09:09:33 +0200
commit31daadb27799060ca38779bbbc2327b91dac935b (patch)
tree8a58963be87719d4497d4f54064b870ee5e12947 /dev-ruby/actionview
parentdev-ruby/activejob: add 5.2.8.1 (diff)
downloadgentoo-31daadb27799060ca38779bbbc2327b91dac935b.tar.gz
gentoo-31daadb27799060ca38779bbbc2327b91dac935b.tar.bz2
gentoo-31daadb27799060ca38779bbbc2327b91dac935b.zip
dev-ruby/actionview: add 5.2.8.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actionview')
-rw-r--r--dev-ruby/actionview/Manifest1
-rw-r--r--dev-ruby/actionview/actionview-5.2.8.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/actionview/Manifest b/dev-ruby/actionview/Manifest
index fc66f1549b33..429aee5da292 100644
--- a/dev-ruby/actionview/Manifest
+++ b/dev-ruby/actionview/Manifest
@@ -1,3 +1,4 @@
+DIST rails-5.2.8.1.tgz 8848345 BLAKE2B 6786359e6c519e98079dc6f87a1ad23a69e7b65d2e688e9f09bd446012a18e76173d2997c125dd0260ece78114be9462d8c3dfb3464c6428734377f793828a9f SHA512 05e3bd1fb50c87ba31d47d99748b2edafa2e58dbf4e0c4ee991b7c65e68abbbc794d8f385836fa1fddcd277f78edeb1f9c2d675c1c53403c1f230593a8bd2c71
DIST rails-5.2.8.tgz 8847449 BLAKE2B 11937ee2aeea39cade43829a01430315a997fef070fc73a1e63baaff8b3631f82561c7acdd44cf1981501424be68d814001dd26cbf7678ca987a8311d109d367 SHA512 98e1b36bdd4235e983d0805b6ff9779e3793d1bed486dc6de854215c4294334d5036157a527c1222cc2be4c107754553dadf2bf86e65ce6561dd8152c47ef84a
DIST rails-6.0.5.1.tgz 18607954 BLAKE2B 74f75399a287f1eae199a5764c952b75dd95a02c88899ade69d60acae00a7588b2f3a8ab3b9d2c9224d62f87305c596e16b196a5c32b19731d4415f17a29d38e SHA512 a65c3fab39eadba75e0107486c82a4da212e612ddb2350f77bb00ad887e0b52980edba08d42c02801c4e4fd71d750de3dbd78c820ef050016867737dccc06b36
DIST rails-6.0.5.tgz 18572922 BLAKE2B cc7f3669f5d501031ea5bfcef24db89040dc447923abe255b4ae504c07c648414a19a5d2c7ecb513cb96cf601440caeb2462c37fdae61770cef60ce5708abcb4 SHA512 5f262f65de2e3057b92fdb95bef28ea8c4c44e5ca27f4065bb4946a760b3f97fde10f9a303ccf1fdbf833f1e26db5cde722183f41672614203c4b08aef6780ed
diff --git a/dev-ruby/actionview/actionview-5.2.8.1.ebuild b/dev-ruby/actionview/actionview-5.2.8.1.ebuild
new file mode 100644
index 000000000000..e1a811f6d6d9
--- /dev/null
+++ b/dev-ruby/actionview/actionview-5.2.8.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="app"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1:* =dev-ruby/builder-3*:*
+ >=dev-ruby/erubi-1.4:0
+ >=dev-ruby/rails-html-sanitizer-1.0.3:1
+ dev-ruby/rails-dom-testing:2
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/railties-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|rack-cache\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|bcrypt\|uglifier\|mime-types\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid activerecord integration tests because they are very sensitive to the specifics
+ # of the environment.
+ sed -i -e 's/, "test:integration:active_record"//' Rakefile || die
+
+ sed -e '2igem "actionpack", "~> 5.2.0"' \
+ -e '2igem "activemodel", "~> 5.2.0"' \
+ -e '2igem "railties", "~> 5.2.0"' \
+ -e '/active_record/ s:^:#:' \
+ -i test/abstract_unit.rb || die
+}