summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-16 06:34:46 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-16 06:34:46 +0200
commitae38eba921f9f3889b866de273847523e9a030fa (patch)
tree7335ad6317f4e63be343e772d44d6aa75a64e605 /dev-ruby/amatch
parentsys-firmware/broadcom-bt-firmware: keyword 12.0.1.1105_p3 for ~ppc64 (diff)
downloadgentoo-ae38eba921f9f3889b866de273847523e9a030fa.tar.gz
gentoo-ae38eba921f9f3889b866de273847523e9a030fa.tar.bz2
gentoo-ae38eba921f9f3889b866de273847523e9a030fa.zip
dev-ruby/amatch: add 0.4.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/amatch')
-rw-r--r--dev-ruby/amatch/Manifest1
-rw-r--r--dev-ruby/amatch/amatch-0.4.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/amatch/Manifest b/dev-ruby/amatch/Manifest
index 396ea68f4d34..41f68f080440 100644
--- a/dev-ruby/amatch/Manifest
+++ b/dev-ruby/amatch/Manifest
@@ -1 +1,2 @@
DIST amatch-0.4.0.gem 38912 BLAKE2B 065b4c537a2727cbb7f7d52aff545a3f7f8434b37553e59b261d9760ed304c24a20e4778c375e7b7fa11f40655cac786ca15cdb11360ac7296f03186439be480 SHA512 c5a1d17b46f51796d3f082ab9d18845625a28e08339756ebc0689ad6c50b1406611fd5a316e628e4dab6d9b654c969a4fc6e8c2b2079f04c64e3d990e95a64a0
+DIST amatch-0.4.1.gem 38912 BLAKE2B b485442f9b45dcd02bdff641a68cdbce0e15e81bcaddc71a792b6707621092e0f8181d194db49e82abfb3bf692e0b7ac27b21baed3004b3b5a4dfcdb8bff7d4c SHA512 98befe4cb5a78a754eb3596a55b7c004fbf26ba04a8e8314dd6f28b50feade0fc0a7b78493310de0a75b33720204e8ba9ccb05df4478b2631d15b7d9d62a42a9
diff --git a/dev-ruby/amatch/amatch-0.4.1.ebuild b/dev-ruby/amatch/amatch-0.4.1.ebuild
new file mode 100644
index 000000000000..c435a13d7944
--- /dev/null
+++ b/dev-ruby/amatch/amatch-0.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Approximate Matching Extension for Ruby"
+HOMEPAGE="https://flori.github.com/amatch/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/tins-1*"
+
+# These packages also provide agrep, bug 626480
+RDEPEND+=" !app-misc/glimpse !app-text/agrep !dev-libs/tre"
+
+all_ruby_prepare() {
+ # mize is listed as a dependency but not actually used
+ sed -i -e '/mize/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb-2 tests/* || die
+}