summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-07-13 06:52:07 +0200
committerHans de Graaff <graaff@gentoo.org>2020-07-14 05:26:57 +0200
commit981319983f7b9ef6dd29f71637b2996f66569e45 (patch)
tree6503b7b9319118ad83f2d7ac7dbab3990373e670 /dev-ruby/autoprefixer-rails/autoprefixer-rails-9.8.5.ebuild
parentx11-themes/gnome-backgrounds: Version bump to 3.36.0 (diff)
downloadgentoo-981319983f7b9ef6dd29f71637b2996f66569e45.tar.gz
gentoo-981319983f7b9ef6dd29f71637b2996f66569e45.tar.bz2
gentoo-981319983f7b9ef6dd29f71637b2996f66569e45.zip
dev-ruby/autoprefixer-rails: add 9.8.5
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/autoprefixer-rails/autoprefixer-rails-9.8.5.ebuild')
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-9.8.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-9.8.5.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-9.8.5.ebuild
new file mode 100644
index 000000000000..bc06b1290578
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-9.8.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs:*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rails-5.0.0
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/,+3d" \
+ -e '/config.sass/ s:^:#:' spec/app/config/application.rb || die
+ sed -i -e '/standard/ s:^:#:' autoprefixer-rails.gemspec || die
+ sed -i -e '1igem "tzinfo", "~>1.0"' spec/spec_helper.rb || die
+ rm -f spec/rails_spec.rb || die
+}