summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-07 06:40:15 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-07 06:40:15 +0200
commit2642f7693a9996f5c7bde32537bc5d1e5a25c228 (patch)
tree7d5cd61e141aa9e97649a4d0b67e66d95b4589a6 /dev-ruby/awesome_print/awesome_print-1.7.0.ebuild
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-2642f7693a9996f5c7bde32537bc5d1e5a25c228.tar.gz
gentoo-2642f7693a9996f5c7bde32537bc5d1e5a25c228.tar.bz2
gentoo-2642f7693a9996f5c7bde32537bc5d1e5a25c228.zip
dev-ruby/awesome_print: add 1.7.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/awesome_print/awesome_print-1.7.0.ebuild')
-rw-r--r--dev-ruby/awesome_print/awesome_print-1.7.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/awesome_print/awesome_print-1.7.0.ebuild b/dev-ruby/awesome_print/awesome_print-1.7.0.ebuild
new file mode 100644
index 000000000000..bea73ff73b82
--- /dev/null
+++ b/dev-ruby/awesome_print/awesome_print-1.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library to pretty print Ruby objects in full color with proper indentation"
+HOMEPAGE="https://github.com/awesome-print/awesome_print"
+SRC_URI="https://github.com/awesome-print/awesome_print/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/codeclimate/I s:^:#:' spec/spec_helper.rb || die
+}