summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/bson/bson-1.12.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/bson/bson-1.12.0.ebuild')
-rw-r--r--dev-ruby/bson/bson-1.12.0.ebuild108
1 files changed, 108 insertions, 0 deletions
diff --git a/dev-ruby/bson/bson-1.12.0.ebuild b/dev-ruby/bson/bson-1.12.0.ebuild
new file mode 100644
index 000000000000..befe2778ad76
--- /dev/null
+++ b/dev-ruby/bson/bson-1.12.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="moot" # we do it manually, but still declare it
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="mongo-ruby-driver"
+RUBY_S="${GITHUB_PROJECT}-${PV}"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/${PV}.tar.gz -> ${GITHUB_PROJECT}-${PV}.tar.gz"
+
+LICENSE="APSL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+ruby_add_bdepend \
+ "test? (
+ dev-ruby/bundler
+ >=dev-ruby/rake-10.1
+ dev-ruby/sfl
+ >=dev-ruby/shoulda-3.3.2
+ dev-ruby/mocha
+ dev-ruby/test-unit:2
+ )
+ doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # remove the stuff that is actually part of dev-ruby/mongo
+ rm -f bin/mongo* || die
+
+ # Avoid test dependency on pry
+ sed -i -e '/\(pry\|coverall\)/I s:^:#:' Gemfile tasks/testing.rake test/test_helper.rb || die
+ # Avoid deployment dependencies and fix version issues
+ sed -i -e '/rest-client/ s/1.6.8/~> 1.6/' \
+ -e '/test-unit/ s/~>2.0/>= 2.0/' \
+ -e '/rake/ s/10.1.1/~>10.1/' \
+ -e '/:deploy/,/end/ s:^:#:' Gemfile || die
+
+ # Don't clean up the compiled version after testing
+ sed -i -e '/:cleanup/,/end/ s:lib/bson_ext::' tasks/testing.rake || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/cbson extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/cbson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ mkdir -p lib/bson_ext || die
+ cp ext/cbson/*$(get_modname) lib/bson_ext || die
+}
+
+all_ruby_compile() {
+ # Trying to get the Rakefile to build the sources is more trouble
+ # than it's worth, do it manually instead.
+ if use doc; then
+ rdoc --op html --inline-source lib/**/*.rb || die "rdoc failed"
+ fi
+}
+
+each_ruby_test() {
+ C_EXT=true JENKINS_CI=true ${RUBY} -S rake test:bson || die "tests failed"
+}
+
+each_ruby_install() {
+ # Remove remaining mongo code that will be installed as part of
+ # dev-ruby/mongo. We do this here rather than in src_prepare so we
+ # can bootstrap with tests enabled.
+ rm -rf lib/mongo* || die
+
+ # we have to set the library path here because the gemspec tries to
+ # load bson itself, and would fail without that.
+ RUBYLIB="lib" \
+ each_fakegem_install
+
+ # and now we create the simulated gem for bson_ext; we create a file
+ # bson_ext.rb within ext so that we don't have to change the
+ # bson_ext.gemspec file, and at the same time we ensure that bson
+ # gem is loaded when loading bson_ext.
+ dodir $(ruby_fakegem_gemsdir)/gems/bson_ext-${PV}/ext
+ cat - <<EOF > "${D}/$(ruby_fakegem_gemsdir)/gems/bson_ext-${PV}/ext/bson_ext.rb"
+require 'bson'
+EOF
+
+ RUBYLIB="lib" \
+ RUBY_FAKEGEM_NAME=bson_ext \
+ RUBY_FAKEGEM_GEMSPEC=bson_ext.gemspec \
+ ruby_fakegem_install_gemspec
+}
+
+pkg_postinst() {
+ elog "Unlike upstream setup, we do not split bson and bson_ext gem."
+ elog "This means that for all the supported targets, the C-based extension"
+ elog "is installed by this package, and is available transparently."
+}