summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-09-06 08:01:14 +0200
committerHans de Graaff <graaff@gentoo.org>2015-09-06 08:23:49 +0200
commitf70354028b76abbd561305c93536947f62283a97 (patch)
treef82aa46925246df8a5d17bd16e1e40a3751f88d6 /dev-ruby/bson/bson-3.2.4.ebuild
parentapp-editors/gvim: Stable for HPPA PPC64 (bug #551552). (diff)
downloadgentoo-f70354028b76abbd561305c93536947f62283a97.tar.gz
gentoo-f70354028b76abbd561305c93536947f62283a97.tar.bz2
gentoo-f70354028b76abbd561305c93536947f62283a97.zip
dev-ruby/bson: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/bson/bson-3.2.4.ebuild')
-rw-r--r--dev-ruby/bson/bson-3.2.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/bson/bson-3.2.4.ebuild b/dev-ruby/bson/bson-3.2.4.ebuild
new file mode 100644
index 000000000000..0627cb8ec76c
--- /dev/null
+++ b/dev-ruby/bson/bson-3.2.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove project-specific rspec options
+ rm .rspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/bson/*$(get_modname) lib/ || die
+}