summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-05-24 08:33:56 +0200
committerHans de Graaff <graaff@gentoo.org>2019-05-24 09:06:04 +0200
commit54db14633b18fbc0123e4370a99fb0a0a076e295 (patch)
treef7049eb22fad534ab7734e251b4e89b48421e1c0 /dev-ruby/bson
parentvirtual/perl-version: ppc64 stable wrt bug #685664 (diff)
downloadgentoo-54db14633b18fbc0123e4370a99fb0a0a076e295.tar.gz
gentoo-54db14633b18fbc0123e4370a99fb0a0a076e295.tar.bz2
gentoo-54db14633b18fbc0123e4370a99fb0a0a076e295.zip
dev-ruby/bson: add 4.5.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/bson')
-rw-r--r--dev-ruby/bson/Manifest1
-rw-r--r--dev-ruby/bson/bson-4.5.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/bson/Manifest b/dev-ruby/bson/Manifest
index d02accca3df5..05507223c091 100644
--- a/dev-ruby/bson/Manifest
+++ b/dev-ruby/bson/Manifest
@@ -1 +1,2 @@
DIST bson-4.4.2.tar.gz 107429 BLAKE2B 94b3f694d79a3219a6e7b13f4dfa5935a1fec5ac99883918d61052786b2e033d8cd335013155b4b9069a730a3a87a0c0ec00b8b5ee5b89bb8c357909e8f67fe4 SHA512 a27a82fab17f596df986a3c81f1e73146a8d283bb16e8a7dba1921215e8f0e863b6996dbc107ede44546e750e4b19cc2dd934d290e25712472efd6cc075b9984
+DIST bson-4.5.0.tar.gz 107547 BLAKE2B fddbb84ee74c3b6bb50a79141e583b300deeaa85b7b39b4e26985fa1cd0c741813eb4b3192fffe97d8bb238430087e4726004e8d3c50d39f17f8b270b8635dc4 SHA512 093a4906961d765bdd49febbe9c3123a34d3f80adc5e1309abb2b5fc1380bff37c9d8df475bfb29fc9359cf440813e716ff359e461f5e7f6d5e1e02009bc24bd
diff --git a/dev-ruby/bson/bson-4.5.0.ebuild b/dev-ruby/bson/bson-4.5.0.ebuild
new file mode 100644
index 000000000000..da73b88ea528
--- /dev/null
+++ b/dev-ruby/bson/bson-4.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="https://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove project-specific rspec options
+ rm .rspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/bson/*$(get_modname) lib/ || die
+}