summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-01-19 08:54:06 +0100
committerHans de Graaff <graaff@gentoo.org>2019-01-19 08:54:06 +0100
commitb8481c0877b9cf98cd997c18b876d38abbafa4e7 (patch)
treec659694b56fbdc7ee2b0c779efd9ed7c3c84fbad /dev-ruby/bson
parentdev-ruby/maruku: add ruby26 (diff)
downloadgentoo-b8481c0877b9cf98cd997c18b876d38abbafa4e7.tar.gz
gentoo-b8481c0877b9cf98cd997c18b876d38abbafa4e7.tar.bz2
gentoo-b8481c0877b9cf98cd997c18b876d38abbafa4e7.zip
dev-ruby/bson: add 4.4.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/bson')
-rw-r--r--dev-ruby/bson/Manifest1
-rw-r--r--dev-ruby/bson/bson-4.4.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/bson/Manifest b/dev-ruby/bson/Manifest
index d53d69ea5910..4d233cda9898 100644
--- a/dev-ruby/bson/Manifest
+++ b/dev-ruby/bson/Manifest
@@ -1,2 +1,3 @@
DIST bson-4.2.2.tar.gz 96725 BLAKE2B 62c40df519e185665f0c42bc8ab6a2d8472d123397f1ed1403e40254944cd423e6cedbfa014a03f6c6ed8a7cde94f8c26d06e784b82ea55f17a97996915381d6 SHA512 4de8950271f5fdd5927eda290b6506248012cb8a932d65773ad53f1e3e4c67ea17575b559447d5eb6c9286f672439879dbc89aa0cded4ec2d0fa35c49da7a574
DIST bson-4.3.0.tar.gz 103341 BLAKE2B 29f7d870ce85e4984f47fda482b9ebc33986332eefcc3d9c5d56f7cc628e698a4a2e879225b81c6d0b1edc9e62f9b426f2510b67b51398a699d96de390544efb SHA512 c753bd68df5871a7cbed78dc68791a5d1c30db5975b70702742f12373afb754df8078d2bc6a772fd398815bca05a2fa020cc820a1ea9238f8b01eb492581b17f
+DIST bson-4.4.1.tar.gz 106995 BLAKE2B e10bf988c139ba4ffc1649f8f80dea0f7815c46ffe6d3bd35c522391879feb2996c161429bf4a5da2c092ab20fa9dcd544dd187bf3bb3a1baebb48df7c6be6d9 SHA512 740149ca01698998721cb6f585dd727ddc26ea770a16e5a6dc2d5faf6e52388ce8804a44b2c2ad1e52085dc810b522f4f320b72757c62cc7378ce6af84714d2a
diff --git a/dev-ruby/bson/bson-4.4.1.ebuild b/dev-ruby/bson/bson-4.4.1.ebuild
new file mode 100644
index 000000000000..fef1520820fd
--- /dev/null
+++ b/dev-ruby/bson/bson-4.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove project-specific rspec options
+ rm .rspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/bson/*$(get_modname) lib/ || die
+}