summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/childprocess
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/childprocess')
-rw-r--r--dev-ruby/childprocess/Manifest3
-rw-r--r--dev-ruby/childprocess/childprocess-0.5.3.ebuild35
-rw-r--r--dev-ruby/childprocess/childprocess-0.5.5.ebuild35
-rw-r--r--dev-ruby/childprocess/childprocess-0.5.6.ebuild35
-rw-r--r--dev-ruby/childprocess/metadata.xml8
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-ruby/childprocess/Manifest b/dev-ruby/childprocess/Manifest
new file mode 100644
index 000000000000..8b0db1fd8199
--- /dev/null
+++ b/dev-ruby/childprocess/Manifest
@@ -0,0 +1,3 @@
+DIST childprocess-0.5.3.gem 28160 SHA256 9cebed1bd68f7ba0deb54683a5c05a8c3e79037f682b5d0a6ecd1d4472bbb289 SHA512 f48ab94dc3da7ca82551f480cb18214ec65f9550ef053b25216239ed92c289a7353c632fff53148b1d6ce0c7bf70188bcecbdeede3df9b8130f815599a45ac05 WHIRLPOOL 68f7e9585c39a2628c4cb162d02c7d332d116be96ce8f325308e15d530e00139d43b9dcfcdfd490c6a252057947eed4c91843d8f37b96201d95b6ff3078055da
+DIST childprocess-0.5.5.gem 28672 SHA256 9b583295a11932d2eeffa1e8f5b8fb2fb0064a2f0111ad98c3b752b94f80bf33 SHA512 313f9e66da6c6e06045fd5fc9b1d87cac23ca9b2d7fc6ebcc7dd900484a3807653e5c12728fdbf65a5d82a1085f5ccdaae36561e6993684b612cea0151fa591d WHIRLPOOL b92b8756c467c0af2155bf02732cf86bc8e3907c7ac99aef7f2709bf19da1f16aa17f53ead47f7ffe8f88c3d33bb81b2c36c45dd9a6141175ad0438f1942a0ce
+DIST childprocess-0.5.6.gem 28672 SHA256 999933231b469b095b1d4b24cbe3ea159f215771650ff47f77e46540192ebd48 SHA512 b4e7c7095028d03002d54d6cf05c43fb6792a3284cb879d1a29090219b6eea9e945b06f9906c308f4f1c73bb79bece178c67c17da22a1a78ad30b8f96b67df04 WHIRLPOOL 70c1e28041a7a9c86c6e0d2056c4563751614353ee97dd1539115e379140211bf86c72fdeb2e611bba45791a967e6e77338c62766102484213dfc0695c6d6cea
diff --git a/dev-ruby/childprocess/childprocess-0.5.3.ebuild b/dev-ruby/childprocess/childprocess-0.5.3.ebuild
new file mode 100644
index 000000000000..f89823fe620b
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple and reliable solution for controlling external programs running in the background"
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:2 )"
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/childprocess/childprocess-0.5.5.ebuild b/dev-ruby/childprocess/childprocess-0.5.5.ebuild
new file mode 100644
index 000000000000..c8ceba76a36b
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.5.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple and reliable solution for controlling external programs running in the background"
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:2 )"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/childprocess/childprocess-0.5.6.ebuild b/dev-ruby/childprocess/childprocess-0.5.6.ebuild
new file mode 100644
index 000000000000..d9cf626acc8f
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.5.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple and reliable solution for controlling external programs running in the background"
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:2 )"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/childprocess/metadata.xml b/dev-ruby/childprocess/metadata.xml
new file mode 100644
index 000000000000..57700e2d3d45
--- /dev/null
+++ b/dev-ruby/childprocess/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jarib/childprocess</remote-id>
+ </upstream>
+</pkgmetadata>