summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-06-02 06:49:34 +0200
committerHans de Graaff <graaff@gentoo.org>2020-06-02 06:49:34 +0200
commitcb81ed453a3f10aebe6118ecec9181036d83df08 (patch)
tree9204500aa583839bca79f107baa979e094ae213e /dev-ruby/coderay
parentdev-ruby/uglifier: add ruby27 (diff)
downloadgentoo-cb81ed453a3f10aebe6118ecec9181036d83df08.tar.gz
gentoo-cb81ed453a3f10aebe6118ecec9181036d83df08.tar.bz2
gentoo-cb81ed453a3f10aebe6118ecec9181036d83df08.zip
dev-ruby/coderay: add 1.1.3
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/Manifest1
-rw-r--r--dev-ruby/coderay/coderay-1.1.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/coderay/Manifest b/dev-ruby/coderay/Manifest
index 0efe78a971d4..96ebaa024b4d 100644
--- a/dev-ruby/coderay/Manifest
+++ b/dev-ruby/coderay/Manifest
@@ -1 +1,2 @@
DIST coderay-1.1.2.tar.gz 220645 BLAKE2B 85405da2b148ae23573abf2c3fcf94a643024756308e83c4cecf0a5edae2fedc4ca7c7bdf8fb5936310f6699ca8f06f91cceb475e00511a54af0a96dd517c234 SHA512 cfce5e9f0a0d988e7920912e064ecbef3b54200a08ca2e07453452edd7f382a1eb9292bc566e069f5d1b784033e816f13d9ddfb39520e8e44a8d1e898aa33591
+DIST coderay-1.1.3.tar.gz 229139 BLAKE2B a900cc5fbac950f66814d9300876d6a273b296d07139297d5344d26c5710d23c37761e5743ef972f523afa20fa663f239c03d9d2ad47232b77e53fe5053736f0 SHA512 a5208965e8dbad53d179fdc1c57df59ba4e13522a1a57c371ccd3f9369408a1c7d878867df48b201a1d590b46ef0f9bada3f3e7810866f17d244b5b370aba3fb
diff --git a/dev-ruby/coderay/coderay-1.1.3.ebuild b/dev-ruby/coderay/coderay-1.1.3.ebuild
new file mode 100644
index 000000000000..8f6f8414aeb7
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="coderay.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting"
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Redcloth is an optional but automagically tested dependency. This
+# requires redcloth-4.2.2. We don't depend on this version to make
+# bootstrapping rspec with new versions easier, since redcloth depends
+# on rake-compiler.
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/git ls-files/ s:^:#:' coderay.gemspec || die
+
+ # Fix failing tests for lazy evaluation in ruby26
+ sed -i -e 's/\.filter$/.filter.to_a/' test/unit/filter.rb || die
+}