summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/daemon_controller
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/daemon_controller')
-rw-r--r--dev-ruby/daemon_controller/Manifest2
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.1.8.ebuild28
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild27
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.2.0.ebuild28
-rw-r--r--dev-ruby/daemon_controller/metadata.xml8
5 files changed, 93 insertions, 0 deletions
diff --git a/dev-ruby/daemon_controller/Manifest b/dev-ruby/daemon_controller/Manifest
new file mode 100644
index 000000000000..10e5b26c69a2
--- /dev/null
+++ b/dev-ruby/daemon_controller/Manifest
@@ -0,0 +1,2 @@
+DIST daemon_controller-1.1.8.gem 34304 SHA256 4eb3733d4544c2a19588e099957b0599167c7b3cb1668489242a9e78614036b8 SHA512 48e916e5ae30f8133c856c39dfe36a1cb5bb0320bf3e799fbfc7741aa973c0e6ecfbdc8063c4d06705624616ca8868b899a18c81aa7cfe146790a8075c1ed7f9 WHIRLPOOL d9c494f1d480f4c7b4938bcca3e37bb04c72cf45a6855975a77310da5fa64e4a899bd0c06ec016736ff9429c81a27cfdbef0b36d2108cb6207134f191a09270c
+DIST daemon_controller-1.2.0.gem 37888 SHA256 6d4b4589f7f8ed2201e857a9f0c80a5c3c19548c5b7b5df55794299fd981aa0b SHA512 d22b5f37a41f2fab642cc7a6f5b5ea8a892d2c8b9eda04c9a547ee3aab3148a8897bc4737fd30fd9eb6e2a4fba458ea5811024fb5ad71b7959f3996dfa7b7705 WHIRLPOOL d7e6322464c5950ede20367cb54360f224339bd35595e16a9415a57c398827bb2a51d1056880fbbbbe50d76dfa32184a6b26b344734f5c380488255eb3bbd69b
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.1.8.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.1.8.ebuild
new file mode 100644
index 000000000000..8620c6715c89
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# jruby → fails tests, looks like Unix sockets are bad on JRuby
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust manner"
+HOMEPAGE="http://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..9b75e2fb562e
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust manner"
+HOMEPAGE="https://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.2.0.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.2.0.ebuild
new file mode 100644
index 000000000000..3cab35597629
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# jruby → fails tests, looks like Unix sockets are bad on JRuby
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust manner"
+HOMEPAGE="http://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}
diff --git a/dev-ruby/daemon_controller/metadata.xml b/dev-ruby/daemon_controller/metadata.xml
new file mode 100644
index 000000000000..69455f42dc06
--- /dev/null
+++ b/dev-ruby/daemon_controller/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">FooBarWidget/daemon_controller</remote-id>
+ </upstream>
+</pkgmetadata>