summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-11 20:31:44 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-12 16:28:32 +0200
commit62eda99ee36f94b47ddf4d5faeddb301a3b638c8 (patch)
treef497e7249a2715fd66ae3e84a442737aec7013c9 /dev-ruby/date_validator
parentdev-ruby/date_validator: add ruby27 (diff)
downloadgentoo-62eda99ee36f94b47ddf4d5faeddb301a3b638c8.tar.gz
gentoo-62eda99ee36f94b47ddf4d5faeddb301a3b638c8.tar.bz2
gentoo-62eda99ee36f94b47ddf4d5faeddb301a3b638c8.zip
dev-ruby/date_validator: cleanup
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/date_validator')
-rw-r--r--dev-ruby/date_validator/Manifest1
-rw-r--r--dev-ruby/date_validator/date_validator-0.9.0.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/date_validator/Manifest b/dev-ruby/date_validator/Manifest
index 32175fbe83da..39e685331cc4 100644
--- a/dev-ruby/date_validator/Manifest
+++ b/dev-ruby/date_validator/Manifest
@@ -1,2 +1 @@
DIST date_validator-0.10.0.gem 12800 BLAKE2B 0cbb11e70cb72a1203c2ec33581d4ed48be346af6998faa89e4323c8c6bf70b5c979b55bc79630153a940697c89ce140eb511538cd55adb0f12566f2f1a317a9 SHA512 4348835898ebfe311a8ea456adc10f7bbfd1dc21daf2678e32b1615ba3eef3d36671f67f533109882f40516c836f23d7e0a4072c9ecaa55a1b0eade0b6aa75b7
-DIST date_validator-0.9.0.gem 12288 BLAKE2B 1a180a88ce4669a29381fae8c9a2407a9026404d0aa2d7be24566ab1f35dfc4a2c17c0c06556c3388e49198dc6bfc11425c2f899c46bcec8a39d6b284269b4e0 SHA512 da7c06d22375cb5ce0e3a1c7d8c84d03c60f5564329d7a6adca4448d386bd26341786e97e6d74d6c7ba820c4437fe88f6dea1e20312b07714f28557bb863c051
diff --git a/dev-ruby/date_validator/date_validator-0.9.0.ebuild b/dev-ruby/date_validator/date_validator-0.9.0.ebuild
deleted file mode 100644
index 6a8969c17220..000000000000
--- a/dev-ruby/date_validator/date_validator-0.9.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_EXTRADOC="Readme.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-# if ever needed
-#GITHUB_USER="codegram"
-#GITHUB_PROJECT="${PN}"
-#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
-HOMEPAGE="https://github.com/codegram/date_validator"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/activemodel-3.0:*
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/minitest
- >=dev-ruby/tzinfo-0.3
- >=dev-ruby/activesupport-3.0
- )
- doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/git ls-files/d' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i \
- -e '/[Bb]undler/s/^/#/' Rakefile || die
- # Fix tests
- sed -i -e "1irequire 'active_support'" test/test_helper.rb || die
-}