summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/descendants_tracker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/descendants_tracker')
-rw-r--r--dev-ruby/descendants_tracker/Manifest1
-rw-r--r--dev-ruby/descendants_tracker/descendants_tracker-0.0.4.ebuild31
-rw-r--r--dev-ruby/descendants_tracker/metadata.xml8
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/descendants_tracker/Manifest b/dev-ruby/descendants_tracker/Manifest
new file mode 100644
index 000000000000..5ab0fe1867ea
--- /dev/null
+++ b/dev-ruby/descendants_tracker/Manifest
@@ -0,0 +1 @@
+DIST descendants_tracker-0.0.4.gem 11264 SHA256 e9c41dd4cfbb85829a9301ea7e7c48c2a03b26f09319db230e6479ccdc780897 SHA512 e079b0ba9b14056707780f1752297c22e81c144fcc7903bc0ef4aa5ad8f343628f493d6d87cc1d5c61cbf8f69066914210eb407b5492aa414949ad799f9a9b69 WHIRLPOOL 1dc202af24c8e8a1bb2603160b6079dcf537772a8ffb4297ca154cb0e49b2f399c785b6fc0a19d173fc72d03b438d4fc630e329abfa1e13880ccbe127a45f17e
diff --git a/dev-ruby/descendants_tracker/descendants_tracker-0.0.4.ebuild b/dev-ruby/descendants_tracker/descendants_tracker-0.0.4.ebuild
new file mode 100644
index 000000000000..45b9e9eeb26e
--- /dev/null
+++ b/dev-ruby/descendants_tracker/descendants_tracker-0.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module that adds descendant tracking to a class"
+HOMEPAGE="https://github.com/dkubb/descendants_tracker"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/thread_safe"
+
+all_ruby_prepare() {
+ # Remove dependency on devtools
+ sed -i -e '/devtools\/spec_helper/d' spec/spec_helper.rb || die
+ sed -i -e '/it_should_behave_like/d' \
+ spec/unit/descendants_tracker/add_descendant_spec.rb || die
+ sed -i -e '/it_should_behave_like/d' \
+ spec/unit/descendants_tracker/descendants_spec.rb || die
+}
diff --git a/dev-ruby/descendants_tracker/metadata.xml b/dev-ruby/descendants_tracker/metadata.xml
new file mode 100644
index 000000000000..5ee6ba630c2d
--- /dev/null
+++ b/dev-ruby/descendants_tracker/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">dkubb/descendants_tracker</remote-id>
+ </upstream>
+</pkgmetadata>