summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/dotenv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/dotenv')
-rw-r--r--dev-ruby/dotenv/Manifest2
-rw-r--r--dev-ruby/dotenv/dotenv-2.0.1.ebuild27
-rw-r--r--dev-ruby/dotenv/dotenv-2.0.2.ebuild27
-rw-r--r--dev-ruby/dotenv/metadata.xml8
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/dotenv/Manifest b/dev-ruby/dotenv/Manifest
new file mode 100644
index 000000000000..9e8bfd87c62d
--- /dev/null
+++ b/dev-ruby/dotenv/Manifest
@@ -0,0 +1,2 @@
+DIST dotenv-2.0.1.tar.gz 12848 SHA256 8c77f85b5c676a3fc7703c45cdcced11b093b173c3e9a8d0edd8d3bf088b635f SHA512 03700400a7158807967bb4a8c61a041f598f07b76733bcbafc4996c6f0d492f456e1dbe5ff3d93ecec419959c7342e419890147f3adb9b9254e4e6a20e048652 WHIRLPOOL 874b468f7811a0ecbf1a36bf3457ad2dd38b1856767c90e17d827f068ec88bc9540b37b1dde6e30b0a9df6bd53771ff91a34a44195fb057acc528342041fd9d8
+DIST dotenv-2.0.2.tar.gz 13269 SHA256 fb6c65a0f5a2eef7b0f45f2356ad1ff71d2504555667ce83ae0d61ca2050d1d1 SHA512 3b932a71b1156b70240ff372c8ff58a3fc8037fec958910951195091ac518b6971f8d9480a00f43da1be006d9fdb86ad2bfda62937a129da92d30f05991dd067 WHIRLPOOL bb1ea40548abe88837d20912eee5bbe3e3702d2cf57ad4df11104b53b726c8d7c6982699ce00f14e47ce12bdb2cd23b9b9913b4e5135507485b14b66c54d78c1
diff --git a/dev-ruby/dotenv/dotenv-2.0.1.ebuild b/dev-ruby/dotenv/dotenv-2.0.1.ebuild
new file mode 100644
index 000000000000..5160c0575b35
--- /dev/null
+++ b/dev-ruby/dotenv/dotenv-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.md Changelog.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Loads environment variables from .env into ENV"
+HOMEPAGE="https://github.com/bkeepers/dotenv"
+SRC_URI="https://github.com/bkeepers/dotenv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/spring dev-ruby/rails )"
+
+each_ruby_prepare() {
+ sed -i -e "s:ruby -v:${RUBY} -v:g" spec/dotenv/parser_spec.rb || die
+}
diff --git a/dev-ruby/dotenv/dotenv-2.0.2.ebuild b/dev-ruby/dotenv/dotenv-2.0.2.ebuild
new file mode 100644
index 000000000000..5160c0575b35
--- /dev/null
+++ b/dev-ruby/dotenv/dotenv-2.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.md Changelog.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Loads environment variables from .env into ENV"
+HOMEPAGE="https://github.com/bkeepers/dotenv"
+SRC_URI="https://github.com/bkeepers/dotenv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/spring dev-ruby/rails )"
+
+each_ruby_prepare() {
+ sed -i -e "s:ruby -v:${RUBY} -v:g" spec/dotenv/parser_spec.rb || die
+}
diff --git a/dev-ruby/dotenv/metadata.xml b/dev-ruby/dotenv/metadata.xml
new file mode 100644
index 000000000000..93b932334586
--- /dev/null
+++ b/dev-ruby/dotenv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">bkeepers/dotenv</remote-id>
+ </upstream>
+</pkgmetadata>