summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-ruby/eventmachine
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-ruby/eventmachine')
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.2.7.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/eventmachine/eventmachine-1.2.7.ebuild b/dev-ruby/eventmachine/eventmachine-1.2.7.ebuild
index ee3b825cbf56..eef8004a177e 100644
--- a/dev-ruby/eventmachine/eventmachine-1.2.7.ebuild
+++ b/dev-ruby/eventmachine/eventmachine-1.2.7.ebuild
@@ -74,7 +74,7 @@ each_ruby_compile() {
for extdir in ext ext/fastfilereader; do
pushd $extdir
# both extensions use C++, so use the CXXFLAGS not the CFLAGS
- emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
+ emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}"
popd
cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
done
@@ -88,5 +88,5 @@ all_ruby_install() {
all_fakegem_install
insinto /usr/share/doc/${PF}/
- doins -r examples || die "Failed to install examples"
+ doins -r examples
}