summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/eventmachine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/eventmachine')
-rw-r--r--dev-ruby/eventmachine/Manifest3
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild70
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.0.3-r2.ebuild69
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.0.7.ebuild84
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.0.8.ebuild84
-rw-r--r--dev-ruby/eventmachine/files/eventmachine-0.12.10-gentoo.patch62
-rw-r--r--dev-ruby/eventmachine/files/eventmachine-0.12.10-https-test.patch22
-rw-r--r--dev-ruby/eventmachine/metadata.xml8
8 files changed, 402 insertions, 0 deletions
diff --git a/dev-ruby/eventmachine/Manifest b/dev-ruby/eventmachine/Manifest
new file mode 100644
index 000000000000..edbd3cf04112
--- /dev/null
+++ b/dev-ruby/eventmachine/Manifest
@@ -0,0 +1,3 @@
+DIST eventmachine-1.0.3.gem 225792 SHA256 34424c87fc517f70ba137fe2281d16b53ce9c13f5cbfc2dda3ada56e96a65827 SHA512 ea4f0b1a2580d14e564641c49f0e3ac2a9c86d916dd2c5e938df22d1d105c00811154d8bfa7a0f9a8ce32783f5398524c70458c161eab2f0591c690e1e6a5573 WHIRLPOOL 52159101a59ba3d9eff28bedbc2baea46c867049de596f72da4d4a5784e79542f291275c61639d3dc6f062150d4819f7343d12e71bae8fc8954956d6d6db36e2
+DIST eventmachine-1.0.7.gem 231424 SHA256 342b7dfa2bc1d43f9b58c4481d81cc9eb5f7c92a5d0eb39739459fcbdd579d4c SHA512 e119de503d41b34f70060f7735f8d047c139aa14c343cc43c34074196f560dfd64e9f274bb7e44556bf8ded112e5476214196b0ec8635a169f8a050771619ffd WHIRLPOOL 3026f0d9e4ffa791487f657bba0db920c3192d97cbab0447e426ee55b176e4ada87079248fd657278cdaa4556ba8f7da7cce4a106c88c4af45d680c2a6f088e1
+DIST eventmachine-1.0.8.gem 232960 SHA256 57ba18d8f76fb43f8842dd17cc3cebc46eea06a5d5033b3131ac8f73c7bc3bbb SHA512 55bfb8a22149495ca70913e6df6b9861cf0e10a512cdd25579064a816eb7e365bd0a03a1219ed23ed99772b9b312e3ce137781cb0890e31fbb5e5f542ba5ef70 WHIRLPOOL e4c295ebb6f931a0773b9fd9618598e56a7e5ec07908159aac4bdfb148b42ef0ee18d10e5f01008d2c435b008565b6d874a6776ab43d3171f372b6c855afbfaa
diff --git a/dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild b/dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..0e8a5f71e4a2
--- /dev/null
+++ b/dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# jruby → has shims for Java handling but tests fail badly, remaining
+# stuck; avoid that for now.
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs"
+HOMEPAGE="http://rubyeventmachine.com"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-libs/openssl"
+RDEPEND="${RDEPEND}
+ dev-libs/openssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Remove package tasks to avoid dependency on rake-compiler.
+ rm rakelib/package.rake || die
+
+ # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
+ sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die
+
+ # Remove the resolver tests since they require network access and
+ # the localhost test fails with an IPv6 localhost.
+ rm tests/test_resolver.rb || die
+}
+
+each_ruby_configure() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
+ popd
+ done
+}
+
+each_ruby_compile() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ # both extensions use C++, so use the CXXFLAGS not the CFLAGS
+ emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
+ popd
+ cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
+ done
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/eventmachine/eventmachine-1.0.3-r2.ebuild b/dev-ruby/eventmachine/eventmachine-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..2bafdeb44f69
--- /dev/null
+++ b/dev-ruby/eventmachine/eventmachine-1.0.3-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# ruby22 - code does not compile
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs"
+HOMEPAGE="http://rubyeventmachine.com"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-libs/openssl"
+RDEPEND="${RDEPEND}
+ dev-libs/openssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Remove package tasks to avoid dependency on rake-compiler.
+ rm rakelib/package.rake || die
+
+ # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
+ sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die
+
+ # Remove the resolver tests since they require network access and
+ # the localhost test fails with an IPv6 localhost.
+ rm tests/test_resolver.rb || die
+}
+
+each_ruby_configure() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
+ popd
+ done
+}
+
+each_ruby_compile() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ # both extensions use C++, so use the CXXFLAGS not the CFLAGS
+ emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
+ popd
+ cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
+ done
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/eventmachine/eventmachine-1.0.7.ebuild b/dev-ruby/eventmachine/eventmachine-1.0.7.ebuild
new file mode 100644
index 000000000000..9ee7dd7c81b3
--- /dev/null
+++ b/dev-ruby/eventmachine/eventmachine-1.0.7.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs"
+HOMEPAGE="http://rubyeventmachine.com"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-libs/openssl:0"
+RDEPEND="${RDEPEND}
+ dev-libs/openssl:0"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Remove package tasks to avoid dependency on rake-compiler.
+ rm rakelib/package.rake || die
+
+ # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
+ sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die
+ sed -i -e "/omit_/d" tests/test_*.rb || die
+ # Remove the resolver tests since they require network access and
+ # the localhost test fails with an IPv6 localhost.
+ rm tests/test_resolver.rb || die
+ # Needs a tty
+ rm tests/test_kb.rb || die
+ # Avoid tests that require network access
+ sed -i -e '/test_bind_connect/,/^ end/ s:^:#:' \
+ tests/test_basic.rb || die
+ sed -i -e '/test_\(cookie\|http_client\|version_1_0\)/,/^ end/ s:^:#:' \
+ tests/test_httpclient.rb || die
+ sed -i -e '/test_\(get\|https_get\)/,/^ end/ s:^:#:' \
+ tests/test_httpclient2.rb || die
+ sed -i -e '/test_connect_timeout/,/^ end/ s:^:#:' \
+ tests/test_unbind_reason.rb || die
+ sed -i -e '/test_for_real/,/^ end/ s:^:#:' \
+ tests/test_pending_connect_timeout.rb || die
+ rm -f tests/test_{get_sock_opt,set_sock_opt,idle_connection}.rb || die
+}
+
+each_ruby_configure() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
+ popd
+ done
+}
+
+each_ruby_compile() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ # both extensions use C++, so use the CXXFLAGS not the CFLAGS
+ emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
+ popd
+ cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
+ done
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/eventmachine/eventmachine-1.0.8.ebuild b/dev-ruby/eventmachine/eventmachine-1.0.8.ebuild
new file mode 100644
index 000000000000..9ee7dd7c81b3
--- /dev/null
+++ b/dev-ruby/eventmachine/eventmachine-1.0.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs"
+HOMEPAGE="http://rubyeventmachine.com"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-libs/openssl:0"
+RDEPEND="${RDEPEND}
+ dev-libs/openssl:0"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Remove package tasks to avoid dependency on rake-compiler.
+ rm rakelib/package.rake || die
+
+ # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
+ sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die
+ sed -i -e "/omit_/d" tests/test_*.rb || die
+ # Remove the resolver tests since they require network access and
+ # the localhost test fails with an IPv6 localhost.
+ rm tests/test_resolver.rb || die
+ # Needs a tty
+ rm tests/test_kb.rb || die
+ # Avoid tests that require network access
+ sed -i -e '/test_bind_connect/,/^ end/ s:^:#:' \
+ tests/test_basic.rb || die
+ sed -i -e '/test_\(cookie\|http_client\|version_1_0\)/,/^ end/ s:^:#:' \
+ tests/test_httpclient.rb || die
+ sed -i -e '/test_\(get\|https_get\)/,/^ end/ s:^:#:' \
+ tests/test_httpclient2.rb || die
+ sed -i -e '/test_connect_timeout/,/^ end/ s:^:#:' \
+ tests/test_unbind_reason.rb || die
+ sed -i -e '/test_for_real/,/^ end/ s:^:#:' \
+ tests/test_pending_connect_timeout.rb || die
+ rm -f tests/test_{get_sock_opt,set_sock_opt,idle_connection}.rb || die
+}
+
+each_ruby_configure() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
+ popd
+ done
+}
+
+each_ruby_compile() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ # both extensions use C++, so use the CXXFLAGS not the CFLAGS
+ emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
+ popd
+ cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
+ done
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/eventmachine/files/eventmachine-0.12.10-gentoo.patch b/dev-ruby/eventmachine/files/eventmachine-0.12.10-gentoo.patch
new file mode 100644
index 000000000000..72b7b72dde5b
--- /dev/null
+++ b/dev-ruby/eventmachine/files/eventmachine-0.12.10-gentoo.patch
@@ -0,0 +1,62 @@
+unchanged:
+--- a/Rakefile
++++ b/Rakefile
+@@ -86,7 +86,7 @@
+ s.rdoc_options = %w(--title EventMachine --main README --line-numbers -x lib/em/version -x lib/emva -x lib/evma/ -x lib/pr_eventmachine -x lib/jeventmachine)
+ s.extra_rdoc_files = Dir['README,docs/*']
+
+- s.files = `git ls-files`.split("\n")
++ s.files = `git ls-files`.split("\n") rescue Errno::ENOENT
+
+ s.require_path = 'lib'
+
+@@ -301,7 +301,7 @@ rescue LoadError
+ require 'rake/rdoctask'
+ Rake::RDocTask
+ end
+-df = begin; require 'rdoc/generator/darkfish'; true; rescue LoadError; end
++df = begin; require 'rdoc/rdoc'; require 'rdoc/generator/darkfish'; true; rescue LoadError; end
+ rdtask = rdoc_task_type.new do |rd|
+ rd.title = Spec.name
+ rd.rdoc_dir = 'rdoc'
+unchanged:
+--- a/tests/test_defer.rb
++++ b/tests/test_defer.rb
+@@ -28,6 +28,7 @@ $:.unshift "../lib"
+ require 'eventmachine'
+ require 'test/unit'
+
++unless RUBY_VERSION >= '1.9.0'
+ class TestDeferUsage < Test::Unit::TestCase
+
+ def test_defers
+@@ -41,7 +42,8 @@ class TestDeferUsage < Test::Unit::TestCase
+ }
+ }
+ assert_equal( n, n_times )
+- end unless RUBY_VERSION >= '1.9.0'
++ end
+
+ end
++end
+
+only in patch2:
+unchanged:
+--- a/tests/test_process_watch.rb
++++ b/tests/test_process_watch.rb
+@@ -2,6 +2,7 @@ $:.unshift "../lib"
+ require 'eventmachine'
+ require 'test/unit'
+
++if EM.kqueue?
+ class TestProcessWatch < Test::Unit::TestCase
+ module ParentProcessWatcher
+ def process_forked
+@@ -45,4 +46,5 @@ class TestProcessWatch < Test::Unit::TestCase
+ assert($exited)
+ assert($unbind)
+ end
+-end
+\ No newline at end of file
++end
++end
diff --git a/dev-ruby/eventmachine/files/eventmachine-0.12.10-https-test.patch b/dev-ruby/eventmachine/files/eventmachine-0.12.10-https-test.patch
new file mode 100644
index 000000000000..d589d71ce650
--- /dev/null
+++ b/dev-ruby/eventmachine/files/eventmachine-0.12.10-https-test.patch
@@ -0,0 +1,22 @@
+commit 63f2debff906a0f51bb807ac8f67c749d72b492d
+Author: Michael S. Klishin <michael@novemberain.com>
+Date: Sun May 23 21:09:03 2010 +0400
+
+ Makes HTTPS client tests pass
+
+ https://www.amazon.com now redirects to http version. Switching site
+ is enough to make the test pass.
+
+diff --git a/tests/test_httpclient2.rb b/tests/test_httpclient2.rb
+index ef72e7c..4705e42 100644
+--- a/tests/test_httpclient2.rb
++++ b/tests/test_httpclient2.rb
+@@ -142,7 +142,7 @@ class TestHttpClient2 < Test::Unit::TestCase
+ def test_https_get
+ d = nil
+ EM.run {
+- http = EM::P::HttpClient2.connect :host => 'www.amazon.com', :port => 443, :ssl => true
++ http = EM::P::HttpClient2.connect :host => 'www.apple.com', :port => 443, :ssl => true
+ d = http.get "/"
+ d.callback {
+ EM.stop
diff --git a/dev-ruby/eventmachine/metadata.xml b/dev-ruby/eventmachine/metadata.xml
new file mode 100644
index 000000000000..090e1e223d75
--- /dev/null
+++ b/dev-ruby/eventmachine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<longdescription>
+Ruby/EventMachine is a fast, simple event-processing library for Ruby programs. It lets you write network clients and servers without handling sockets- all you do is send and receive data. Single-threaded socket engine- scalable and FAST!
+</longdescription>
+</pkgmetadata>