summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-13 09:09:03 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-13 09:09:03 +0100
commit9838a661297ff6337571be778171b4c64cb642d7 (patch)
tree1ee0a8bf6bbd7f4f977318d63702680114fd18a4 /dev-ruby/facter
parentdev-ruby/facter: amd64 stable, bug 575610 (diff)
downloadgentoo-9838a661297ff6337571be778171b4c64cb642d7.tar.gz
gentoo-9838a661297ff6337571be778171b4c64cb642d7.tar.bz2
gentoo-9838a661297ff6337571be778171b4c64cb642d7.zip
dev-ruby/facter: cleanup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/facter')
-rw-r--r--dev-ruby/facter/facter-2.4.1-r1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-ruby/facter/facter-2.4.1-r1.ebuild b/dev-ruby/facter/facter-2.4.1-r1.ebuild
deleted file mode 100644
index 435b30e085c8..000000000000
--- a/dev-ruby/facter/facter-2.4.1-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_BINWRAP="facter"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+dmi +pciutils +virt"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-
-CDEPEND="
- app-emulation/virt-what
- sys-apps/net-tools
- sys-apps/lsb-release
- dmi? ( sys-apps/dmidecode )
- pciutils? ( sys-apps/pciutils )"
-
-RDEPEND+=" ${CDEPEND}"
-DEPEND+=" test? ( ${CDEPEND} )"
-
-ruby_add_bdepend "test? ( dev-ruby/mocha:1.0 )"
-
-all_ruby_prepare() {
- # Provide explicit path since /sbin is not in the default PATH on
- # Gentoo.
- sed -i -e 's:arp -an:/sbin/arp -an:' lib/facter/util/ec2.rb spec/unit/util/ec2_spec.rb || die
-
- # Ensure the correct version of mocha is used without using bundler.
- sed -i -e '1igem "mocha", "~>1.0"' spec/spec_helper.rb || die
-
- # Avoid because tests try to access outside stuff, e.g. /sys/block
- sed -i -e '/should load facts on the facter search path only once/,/^ end/ s:^:#:' spec/unit/util/loader_spec.rb || die
-
- # Allow specs to work with newer rspec 2.x versions.
- sed -i -e '1irequire "rspec-expectations"' spec/puppetlabs_spec/matchers.rb || die
-
- # Avoid specs specific to macosx requiring cfpropertylist which is
- # not available anymore.
- rm spec/unit/util/macosx_spec.rb || die
- sed -i -e '/macosx/ s:^:#:' \
- -e '/on Darwin/,/^ end/ s:^:#:' spec/unit/virtual_spec.rb || die
- sed -i -e '/Facter::Processors::Darwin/,/^end/ s:^:#:' spec/unit/processors/os_spec.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # Create the directory for custom facts.
- keepdir /etc/facter/facts.d
-}