summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-10-05 06:44:27 +0200
committerHans de Graaff <graaff@gentoo.org>2017-10-05 06:45:19 +0200
commit2c1449122287b6b35ec924c2a22fd99da2aedb39 (patch)
treef3806e7f0cb41246c79704fe867ec1320016913f /dev-ruby/factory_girl
parentdev-ruby/patron: add 0.10.0 (diff)
downloadgentoo-2c1449122287b6b35ec924c2a22fd99da2aedb39.tar.gz
gentoo-2c1449122287b6b35ec924c2a22fd99da2aedb39.tar.bz2
gentoo-2c1449122287b6b35ec924c2a22fd99da2aedb39.zip
dev-ruby/factory_girl: add 4.8.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/factory_girl')
-rw-r--r--dev-ruby/factory_girl/Manifest1
-rw-r--r--dev-ruby/factory_girl/factory_girl-4.8.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/factory_girl/Manifest b/dev-ruby/factory_girl/Manifest
index e016cc077a51..0f85c83abb12 100644
--- a/dev-ruby/factory_girl/Manifest
+++ b/dev-ruby/factory_girl/Manifest
@@ -1 +1,2 @@
DIST factory_girl-4.8.0.tar.gz 66025 SHA256 81149a7466ead3f3ecd5e9a4cecd19ca20646901669b2892a62413f54a24036b SHA512 c1e89b25c0dc3292b647179c3cfb487ae235d8049f936beb926c3799e0348ee66e4e6a5d3904fd1a11660477f4c2c993e5d2640a8f54f7cfc5779027d76cca61 WHIRLPOOL 075e04007a9e98c62ca09c4798cfd3dc3e1ebe7025d5b2ae1a2510f9d1a2d34ae9f9fbd56730c09757461d5c546f36517fb914c6c375bebb494409c8db268a4b
+DIST factory_girl-4.8.1.tar.gz 66262 SHA256 874255baaadcd8bedd289b3d8c39343f7ac228a6f43464e7f67f1085fabc6228 SHA512 2c27eaec8351b009bf200e10829128c5fd3e73b0383cebf7f3ccbe062ba362b29f25e5c054ed25245202c85c6ab60c637547a8f3719e2f079c86c83c30db48a0 WHIRLPOOL d3e702547015b75ce51295a1838c9aa757ee1a8c855498a8a0395258c05abba3f5a237a201aaf4e4cf371b9a71b8c5ff9362e0f605937bf9af1aba4b442bb633
diff --git a/dev-ruby/factory_girl/factory_girl-4.8.1.ebuild b/dev-ruby/factory_girl/factory_girl-4.8.1.ebuild
new file mode 100644
index 000000000000..936a4af3f63d
--- /dev/null
+++ b/dev-ruby/factory_girl/factory_girl-4.8.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+# Tests depend on unpackaged appraisal, for now we just run the specs
+# with the version of Rails that is installed.
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="GETTING_STARTED.md NEWS README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="features"
+
+inherit ruby-fakegem
+
+DESCRIPTION="factory_girl provides a framework and DSL for defining and using factories"
+HOMEPAGE="https://github.com/thoughtbot/factory_girl"
+SRC_URI="https://github.com/thoughtbot/factory_girl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/activerecord-3.1[sqlite]
+ dev-ruby/bourne
+ >=dev-ruby/mocha-0.12.8
+ dev-ruby/rspec-its
+ dev-ruby/timecop
+ )
+"
+
+all_ruby_prepare() {
+ # Avoid unneeded test dependencies
+ sed -i -e '/simplecov/ s:^:#:' \
+ -e '1irequire "fileutils"' spec/spec_helper.rb || die
+
+ # Avoid specs that may fail due to more strict rspec 2.99
+ # interpretation.
+ sed -i -e '/callbacks using syntax methods without referencing FactoryGirl explicitly/,/^end/ s:^:#:' spec/acceptance/callbacks_spec.rb || die
+}