summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-01-03 00:38:20 -0500
committerZero_Chaos <zerochaos@gentoo.org>2016-01-03 00:38:20 -0500
commit77d349e0d22657ec0f045c620af0da7c58d877a4 (patch)
tree6f6e60f8ce072135fbcbae6435e4e426a662a5c6 /dev-ruby/faraday/faraday-0.9.2-r1.ebuild
parentdev-ruby/patron: adding ~arm (diff)
downloadgentoo-77d349e0d22657ec0f045c620af0da7c58d877a4.tar.gz
gentoo-77d349e0d22657ec0f045c620af0da7c58d877a4.tar.bz2
gentoo-77d349e0d22657ec0f045c620af0da7c58d877a4.zip
dev-ruby/faraday: adding ~arm
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/faraday/faraday-0.9.2-r1.ebuild')
-rw-r--r--dev-ruby/faraday/faraday-0.9.2-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-ruby/faraday/faraday-0.9.2-r1.ebuild b/dev-ruby/faraday/faraday-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..9352db8c3395
--- /dev/null
+++ b/dev-ruby/faraday/faraday-0.9.2-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="HTTP/REST API client library with pluggable components"
+HOMEPAGE="https://github.com/lostisland/faraday"
+SRC_URI="https://github.com/lostisland/faraday/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+=" test? ( sys-process/lsof )"
+
+ruby_add_rdepend ">=dev-ruby/multipart-post-1.2.0 <dev-ruby/multipart-post-3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/test-unit-2.4
+ dev-ruby/httpclient
+ dev-ruby/rack-test
+ dev-ruby/sinatra
+ dev-ruby/net-http-persistent
+ dev-ruby/patron
+ )"
+
+all_ruby_prepare() {
+ # Remove bundler support.
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/helper.rb || die
+ sed -i -e '/bundler/,/^fi/ s:^:#:' script/test || die
+
+ # Remove simplecov and coveralls support, not needed to run tests.
+ sed -i -e '/simplecov/,/^ end/ s:^:#:' test/helper.rb || die
+
+ # Remove tests for adapters that are not packaged for Gentoo.
+ rm test/adapters/em_http_test.rb test/adapters/em_synchrony_test.rb test/adapters/excon_test.rb test/adapters/typhoeus_test.rb || die
+
+ # The proxy server is already killed, may be OS X vs Linux issue.
+ sed -i -e '138 s/^/#/' script/test || die
+
+ sed -i -e '/git ls-files/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_prepare() {
+ # Make sure the test scripts use the right ruby interpreter
+ sed -i -e 's:ruby:'${RUBY}':' script/* || die
+}
+
+each_ruby_test() {
+ each_fakegem_test
+
+ # Sleep some time to allow the sinatra test server to die
+ einfo "Waiting for test server to stop"
+ sleep 10
+}