summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/fxruby
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/fxruby')
-rw-r--r--dev-ruby/fxruby/Manifest1
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.29-r1.ebuild77
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.29.ebuild77
-rw-r--r--dev-ruby/fxruby/metadata.xml5
4 files changed, 160 insertions, 0 deletions
diff --git a/dev-ruby/fxruby/Manifest b/dev-ruby/fxruby/Manifest
new file mode 100644
index 000000000000..33f27731bd10
--- /dev/null
+++ b/dev-ruby/fxruby/Manifest
@@ -0,0 +1 @@
+DIST fxruby-1.6.29.gem 1894400 SHA256 d6e81d984a27e9abb9f51097a796b0d082ef08d186d2da8e1b948125a9ddb22e SHA512 5438ae48b1e95ef1247c214d44a8334ce54fd8396a7348de4796ab309a554014bd4f82e4a738d9192fe792d4decb91118f66e11e68e38d4a0620be33258b1823 WHIRLPOOL 5cf110f5a7c70ab14c047fb47a2554706adbf978faa46fec625f74651e3397b724e35c8dd805aae20884c826bc9bb17a82bd1891c21a1c08830135bac0602fe2
diff --git a/dev-ruby/fxruby/fxruby-1.6.29-r1.ebuild b/dev-ruby/fxruby/fxruby-1.6.29-r1.ebuild
new file mode 100644
index 000000000000..6c9b99b633bc
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.6.29-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# ruby22 -> fails tests
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_NAME="fxruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt index.html README.rdoc TODO"
+
+inherit multilib virtualx ruby-fakegem toolchain-funcs
+
+DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
+HOMEPAGE="http://www.fxruby.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="examples doc"
+
+CDEPEND="x11-libs/fox:1.6 >=x11-libs/fxscintilla-1.62-r1"
+DEPEND="${DEPEND} ${CDEPEND} dev-lang/swig"
+RDEPEND="${RDEPEND} ${CDEPEND}"
+
+ruby_add_bdepend "test? ( dev-ruby/ruby-opengl )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ sed -i -e '/\[:compile\]/d' Rakefile || die
+ einfo "Avoid -O0 builds"
+ sed -i -e 's:-O0 -I:-I:' \
+ ext/fox16_c/extconf.rb || die "Can't fix forced -O0"
+
+ # Use a more modern swig.
+ sed -i -e 's/swig-1.3.22/swig/g' Rakefile || die
+
+ # Remove failing tests. We did not run tests before so this is not a
+ # regression for now.
+ rm test/TC_FXFileStream.rb test/TC_FXId.rb test/TC_FXMainWindow.rb test/TC_FXMaterial.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/fox16_c extconf.rb || die
+}
+
+each_ruby_compile() {
+ CXX=$(tc-getCXX) emake V=1 -Cext/fox16_c || die
+ cp ext/fox16_c/fox16_c$(get_modname) lib/ || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --main rdoc-sources/README.rdoc --exclude ext/fox16_c --exclude "/aliases|kwargs|missingdep|responder/" || die
+}
+
+each_ruby_test() {
+ VIRTUALX_COMMAND=${RUBY} virtualmake -S testrb -Ilib test/TC_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ for dir in sample samples example examples; do
+ if [ -d ${dir} ] ; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR ${dir} "${D}"/usr/share/doc/${PF} || die "cp failed"
+ fi
+ done
+ fi
+}
diff --git a/dev-ruby/fxruby/fxruby-1.6.29.ebuild b/dev-ruby/fxruby/fxruby-1.6.29.ebuild
new file mode 100644
index 000000000000..29835299f474
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.6.29.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# ruby22 -> fails tests
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_NAME="fxruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt index.html README.rdoc TODO"
+
+inherit multilib virtualx ruby-fakegem toolchain-funcs
+
+DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
+HOMEPAGE="http://www.fxruby.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~x86-fbsd"
+IUSE="examples doc"
+
+CDEPEND="x11-libs/fox:1.6 >=x11-libs/fxscintilla-1.62-r1"
+DEPEND="${DEPEND} ${CDEPEND} dev-lang/swig"
+RDEPEND="${RDEPEND} ${CDEPEND}"
+
+ruby_add_bdepend "test? ( dev-ruby/ruby-opengl )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ sed -i -e '/\[:compile\]/d' Rakefile || die
+ einfo "Avoid -O0 builds"
+ sed -i -e 's:-O0 -I:-I:' \
+ ext/fox16_c/extconf.rb || die "Can't fix forced -O0"
+
+ # Use a more modern swig.
+ sed -i -e 's/swig-1.3.22/swig/g' Rakefile || die
+
+ # Remove failing tests. We did not run tests before so this is not a
+ # regression for now.
+ rm test/TC_FXFileStream.rb test/TC_FXId.rb test/TC_FXMainWindow.rb test/TC_FXMaterial.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/fox16_c extconf.rb || die
+}
+
+each_ruby_compile() {
+ CXX=$(tc-getCXX) emake V=1 -Cext/fox16_c || die
+ cp ext/fox16_c/fox16_c$(get_modname) lib/ || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --main rdoc-sources/README.rdoc --exclude ext/fox16_c --exclude "/aliases|kwargs|missingdep|responder/" || die
+}
+
+each_ruby_test() {
+ VIRTUALX_COMMAND=${RUBY} virtualmake -S testrb -Ilib test/TC_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ for dir in sample samples example examples; do
+ if [ -d ${dir} ] ; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR ${dir} "${D}"/usr/share/doc/${PF} || die "cp failed"
+ fi
+ done
+ fi
+}
diff --git a/dev-ruby/fxruby/metadata.xml b/dev-ruby/fxruby/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/fxruby/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>