summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-03 07:56:38 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-03 08:05:00 +0200
commit3eefc33636387c1cac918130e417799bc5b8c614 (patch)
tree1912de983d2ac7ccf6b757b217675a6f14fac634 /dev-ruby/google-protobuf
parentdev-ruby/google-protobuf: cleanup (diff)
downloadgentoo-3eefc33636387c1cac918130e417799bc5b8c614.tar.gz
gentoo-3eefc33636387c1cac918130e417799bc5b8c614.tar.bz2
gentoo-3eefc33636387c1cac918130e417799bc5b8c614.zip
dev-ruby/google-protobuf: add 3.10.0
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/google-protobuf')
-rw-r--r--dev-ruby/google-protobuf/Manifest1
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.10.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/google-protobuf/Manifest b/dev-ruby/google-protobuf/Manifest
index 428aa7f2e5a0..561724bab1c0 100644
--- a/dev-ruby/google-protobuf/Manifest
+++ b/dev-ruby/google-protobuf/Manifest
@@ -1,3 +1,4 @@
+DIST google-protobuf-3.10.0-ruby.tar.gz 4908907 BLAKE2B 53a702a2cbfe7e642989eec010541fda434b7b8bbd267e3b65fc569a0ab33b08438c1a81d478426ebfbec6e330b90428e3da4fd345b8b64f890a6b3f4e360883 SHA512 0dcba6d21486fdc162f57119754b47b4a2fb605af878d5b96a32df55895321535cffb5b804566fd90ee7c36e20106d0cd4f5d9f3c652dc9c4dfca96be41a1977
DIST google-protobuf-3.6.1-ruby.tar.gz 4485582 BLAKE2B 546c49759df784018459809b9db692c5c94aef5d717183af5cd9edd96b4c658e759f23950cdcd5dddceaaad06ea1de2a2357b9fa8c496ed5d538fc5920174da0 SHA512 1bc175d24b49de1b1e41eaf39598194e583afffb924c86c8d2e569d935af21874be76b2cbd4d9655a1d38bac3d4cd811de88bc2c72d81bad79115e69e5b0d839
DIST google-protobuf-3.8.0-ruby.tar.gz 4934577 BLAKE2B 4b86ab216e8a8b2c99c3620da9417c0562498e9d4dbf4957db186f51c62b0ed73b1322635a076b2d4054e015bdf6c8c50cc7fd0cb78d24a93b29d2a5b48f66fe SHA512 ba27c64e5193cd4a144bf0c9dc0d195fbbe6e580aaca01960362f0f185074588ca40046d3bcea76e1deae7508b722f6c5be484ea957122ae8e98229c7c3a4ad2
DIST google-protobuf-3.9.2-ruby.tar.gz 4947582 BLAKE2B ff0150970286d1eb452bd2f252fa8200617ddf491dcb3b9b60cebb36268c5a3072df3d24142ca9863306df6690f53ad4d4761c7846c677c4610716ec22e0838c SHA512 510349ddc59b4e53087b5247ca8784e9f852d66d755e1b014c6214e14c003f31dd336a724e9eb87a5b85a70e22793eb3211744c85a514b24b687346563717bec
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.10.0.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.10.0.ebuild
new file mode 100644
index 000000000000..749ced3b808c
--- /dev/null
+++ b/dev-ruby/google-protobuf/google-protobuf-3.10.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protocol Buffers are Google's data interchange format"
+HOMEPAGE="https://developers.google.com/protocol-buffers"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
+RUBY_S="protobuf-${PV}/ruby"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" test? ( >=dev-libs/protobuf-3.7.0 )"
+
+each_ruby_prepare() {
+ sed -i -e 's:../src/protoc:protoc: ; /^task :build/ s/:compile,//' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/google/protobuf_c extconf.rb
+}
+
+each_ruby_compile() {
+ emake -Cext/google/protobuf_c V=1
+ cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
+}