summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-03 06:39:08 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-03 06:39:08 +0200
commite149138a24f7a525ace99d85eeba4596b2362119 (patch)
treecf332ba0007a112d9ef4ed545d1b9d66e4e6165b /dev-ruby/haml/haml-5.0.2.ebuild
parentdev-ruby/jira-ruby: add 1.4.0 (diff)
downloadgentoo-e149138a24f7a525ace99d85eeba4596b2362119.tar.gz
gentoo-e149138a24f7a525ace99d85eeba4596b2362119.tar.bz2
gentoo-e149138a24f7a525ace99d85eeba4596b2362119.zip
dev-ruby/haml: add 5.0.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/haml/haml-5.0.2.ebuild')
-rw-r--r--dev-ruby/haml/haml-5.0.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/haml/haml-5.0.2.ebuild b/dev-ruby/haml/haml-5.0.2.ebuild
new file mode 100644
index 000000000000..4c1f5904a900
--- /dev/null
+++ b/dev-ruby/haml/haml-5.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby web page templating engine"
+HOMEPAGE="http://haml.info/"
+SRC_URI="https://github.com/haml/haml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~ppc64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+RDEPEND="${RDEPEND} !!<dev-ruby/haml-3.1.8-r2"
+
+ruby_add_rdepend ">=dev-ruby/temple-0.8.0 dev-ruby/tilt:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5
+ dev-ruby/nokogiri
+ dev-ruby/railties:4.2
+ dev-ruby/activemodel:4.2
+ dev-ruby/actionpack:4.2
+ )
+ doc? (
+ dev-ruby/yard
+ >=dev-ruby/maruku-0.7.2-r1
+ )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/ s:^:#:' \
+ -e 's/gem "minitest"/gem "minitest", "~>5.0"/'\
+ -e '1igem "actionpack", "~>4.2"'\
+ -e '1igem "activesupport", "~>4.2"; gem "activemodel", "~>4.2"'\
+ -e '1igem "railties", "~>4.2"'\
+ test/test_helper.rb || die
+ # Remove test that fails when RedCloth is available
+ sed -i -e "/should raise error when a Tilt filters dependencies are unavailable for extension/,/^ end/ s/^/#/"\
+ test/filters_test.rb || die
+}