summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-01-10 09:08:36 +0100
committerHans de Graaff <graaff@gentoo.org>2021-01-10 09:08:36 +0100
commit01df953bffa5d4b40ed18d497351ee0bd081dde1 (patch)
treea2754461ca23f254995ea4d4e47f71be469edecb /dev-ruby/http-parser
parentdev-ruby/paramesan: add 1.0.1 (diff)
downloadgentoo-01df953bffa5d4b40ed18d497351ee0bd081dde1.tar.gz
gentoo-01df953bffa5d4b40ed18d497351ee0bd081dde1.tar.bz2
gentoo-01df953bffa5d4b40ed18d497351ee0bd081dde1.zip
dev-ruby/http-parser: don't hardcode build platform
Closes: https://bugs.gentoo.org/763978 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/http-parser')
-rw-r--r--dev-ruby/http-parser/http-parser-1.2.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/http-parser/http-parser-1.2.2.ebuild b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
index 796554e18319..e3227ecbebf8 100644
--- a/dev-ruby/http-parser/http-parser-1.2.2.ebuild
+++ b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -25,5 +25,5 @@ ruby_add_bdepend "dev-ruby/ffi-compiler"
each_ruby_compile() {
${RUBY} -C ext -S rake || die
- mv ext/x86_64-linux/libhttp-parser-ext.so lib/http-parser/ || die
+ mv ext/*/libhttp-parser-ext.so lib/http-parser/ || die
}