summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-12-25 07:22:43 +0100
committerHans de Graaff <graaff@gentoo.org>2020-12-25 08:12:56 +0100
commit0edb73a350e33ef234f8fa4bbabe9b9b8176ac60 (patch)
tree22edc86ee75b18d377bd08278cacf05e02aaf6aa /dev-ruby/http-parser
parentdev-ruby/ffi-compiler: initial import of 1.0.1 (diff)
downloadgentoo-0edb73a350e33ef234f8fa4bbabe9b9b8176ac60.tar.gz
gentoo-0edb73a350e33ef234f8fa4bbabe9b9b8176ac60.tar.bz2
gentoo-0edb73a350e33ef234f8fa4bbabe9b9b8176ac60.zip
dev-ruby/http-parser: initial import of 1.2.2
New dependency for dev-ruby/http. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/http-parser')
-rw-r--r--dev-ruby/http-parser/Manifest1
-rw-r--r--dev-ruby/http-parser/http-parser-1.2.2.ebuild29
-rw-r--r--dev-ruby/http-parser/metadata.xml11
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/http-parser/Manifest b/dev-ruby/http-parser/Manifest
new file mode 100644
index 000000000000..90d32e89697f
--- /dev/null
+++ b/dev-ruby/http-parser/Manifest
@@ -0,0 +1 @@
+DIST http-parser-1.2.2.gem 32256 BLAKE2B bc1600497db7c0ae9ee9311a6eae6494090b190b49d37809671d0c2fbb3b56ab4709dd16b68c7bfe8fc75609fc6f01d31c21c92681b9adbb4c83e521991d9172 SHA512 cffc1561657b7cb50c446e54da20176870ffe5f1acfe5e9fadfeacbea421fcc89243dd8f4a04d7933e19c155662fcd47db950c3743968d7981c52aa6c0a43ab5
diff --git a/dev-ruby/http-parser/http-parser-1.2.2.ebuild b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
new file mode 100644
index 000000000000..796554e18319
--- /dev/null
+++ b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A super fast http parser for ruby"
+HOMEPAGE="https://github.com/cotag/http-parser"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" >=net-libs/http-parser-2.8.1"
+RDEPEND+=" >=net-libs/http-parser-2.8.1"
+
+ruby_add_bdepend "dev-ruby/ffi-compiler"
+
+each_ruby_compile() {
+ ${RUBY} -C ext -S rake || die
+ mv ext/x86_64-linux/libhttp-parser-ext.so lib/http-parser/ || die
+}
diff --git a/dev-ruby/http-parser/metadata.xml b/dev-ruby/http-parser/metadata.xml
new file mode 100644
index 000000000000..6934c42f882b
--- /dev/null
+++ b/dev-ruby/http-parser/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cotag/http-parser</remote-id>
+ </upstream>
+</pkgmetadata>