summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-28 09:44:32 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-28 10:28:02 +0200
commit6eefe14bf23df36c42234413eabaac35f1815ada (patch)
tree306803022c389856f13943184bbd1780224d0510 /dev-ruby/http_parser_rb
parentdev-ruby/webmock: fix tests (diff)
downloadgentoo-6eefe14bf23df36c42234413eabaac35f1815ada.tar.gz
gentoo-6eefe14bf23df36c42234413eabaac35f1815ada.tar.bz2
gentoo-6eefe14bf23df36c42234413eabaac35f1815ada.zip
dev-ruby/http_parser_rb: enable ruby30, ruby31
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/http_parser_rb')
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
index 26c7f9681990..c8083353aa1e 100644
--- a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -22,3 +22,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86"
IUSE=""
+
+all_ruby_prepare() {
+ # rspec 3 compatibility
+ sed -i -e 's/be_true/be true/; s/be_false/be false/' spec/parser_spec.rb || die
+}