summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-22 22:22:56 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-22 22:23:17 +0100
commitf4da08a9c7a64ea6af6c5acf781814e709553be2 (patch)
treedb1e65a2632a885957edc625144662ba98d1b907 /dev-ruby/httparty
parentmedia-sound/munt-mt32emu-alsadrv: New package (diff)
downloadgentoo-f4da08a9c7a64ea6af6c5acf781814e709553be2.tar.gz
gentoo-f4da08a9c7a64ea6af6c5acf781814e709553be2.tar.bz2
gentoo-f4da08a9c7a64ea6af6c5acf781814e709553be2.zip
dev-ruby/httparty: add ruby24, fix test dependency
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/httparty-0.15.6-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/httparty/httparty-0.15.6-r1.ebuild b/dev-ruby/httparty/httparty-0.15.6-r1.ebuild
new file mode 100644
index 000000000000..8d3f9cac0555
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.15.6-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="https://jnunemaker.github.com/httparty"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'test? ( dev-ruby/webmock )'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
+
+ # Avoid test that works standalone but fails in the suite
+ sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}