summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-03-20 08:38:57 +0100
committerHans de Graaff <graaff@gentoo.org>2021-03-20 08:39:04 +0100
commit05900483c5583f1dd292789685b46c66be4bf04b (patch)
tree30ede38fbff09ab95b5f922de8da7e75ba34079b /dev-ruby/introspection
parentdev-ruby/kramdown: cleanup (diff)
downloadgentoo-05900483c5583f1dd292789685b46c66be4bf04b.tar.gz
gentoo-05900483c5583f1dd292789685b46c66be4bf04b.tar.bz2
gentoo-05900483c5583f1dd292789685b46c66be4bf04b.zip
dev-ruby/introspection: add ruby30
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/introspection')
-rw-r--r--dev-ruby/introspection/introspection-0.0.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/introspection/introspection-0.0.4-r1.ebuild b/dev-ruby/introspection/introspection-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..5554720a0a1f
--- /dev/null
+++ b/dev-ruby/introspection/introspection-0.0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Dynamic inspection of the hierarchy of method definitions on a Ruby object"
+HOMEPAGE="http://jamesmead.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/metaclass-0.0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/blankslate )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}