summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/iobuffer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/iobuffer')
-rw-r--r--dev-ruby/iobuffer/Manifest1
-rw-r--r--dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild41
-rw-r--r--dev-ruby/iobuffer/metadata.xml8
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/iobuffer/Manifest b/dev-ruby/iobuffer/Manifest
new file mode 100644
index 000000000000..2ffca9a09821
--- /dev/null
+++ b/dev-ruby/iobuffer/Manifest
@@ -0,0 +1 @@
+DIST iobuffer-git-1.1.2.tgz 9286 SHA256 41ed7bbb78314ce2115c6842347be1315f92b58c83cee0ed21b80f1d0ddb73ff SHA512 cec67ac42b3966c144fc61c8fa1a36f166d0a892ec4ebb2f6e0fc218eac5fd7bfb803973b05ae52ff05b04eb86caae0cfee4cc1430e876e58157b5bdc41723c7 WHIRLPOOL d0cd3bd87582307bf58504ebfefda9c2acb03e1304af0b84ed5f6f7caf0ee1094c4f374771e12beef74176d063d25cf371175768373195fcbf3b4484bb9b45ee
diff --git a/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild b/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild
new file mode 100644
index 000000000000..e57b245ab701
--- /dev/null
+++ b/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# rbx: Kernel(Autoload)#allocate (method_missing)
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit multilib ruby-fakegem
+
+GITHUB_USER="tarcieri"
+
+DESCRIPTION="IO::Buffer is a fast byte queue which is primarily intended for non-blocking I/O applications"
+HOMEPAGE="http://github.com/tarcieri/iobuffer"
+SRC_URI="http://github.com/${GITHUB_USER}/iobuffer/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+RUBY_S="${GITHUB_USER}-${PN}-*"
+
+all_ruby_prepare() {
+ rm .rspec lib/.gitignore Gemfile* || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die
+ sed -i -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" ext/Makefile || die
+}
+
+each_ruby_compile() {
+ emake -C ext V=1
+ cp ext/iobuffer_ext$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/iobuffer/metadata.xml b/dev-ruby/iobuffer/metadata.xml
new file mode 100644
index 000000000000..b59e1dda0b4c
--- /dev/null
+++ b/dev-ruby/iobuffer/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">tarcieri/iobuffer</remote-id>
+ </upstream>
+</pkgmetadata>