summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/jquery-rails
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/jquery-rails')
-rw-r--r--dev-ruby/jquery-rails/Manifest2
-rw-r--r--dev-ruby/jquery-rails/jquery-rails-3.1.3.ebuild32
-rw-r--r--dev-ruby/jquery-rails/jquery-rails-4.0.4.ebuild35
-rw-r--r--dev-ruby/jquery-rails/metadata.xml5
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/jquery-rails/Manifest b/dev-ruby/jquery-rails/Manifest
new file mode 100644
index 000000000000..bce91681aa02
--- /dev/null
+++ b/dev-ruby/jquery-rails/Manifest
@@ -0,0 +1,2 @@
+DIST jquery-rails-3.1.3.gem 190976 SHA256 07b5b06c60464ea1d86b773eb77c146fc16ecbb6f336b99ee7c1d0d383cc07d8 SHA512 e888eab43036f39335098047bab4c4c4019eccbf73f9eccf952a416dafd46750caa3f7ebd6102f4cee1f8997c585783cc8f77aee4378cda2e074e5291016fe77 WHIRLPOOL 96ab29145a572510143ee69aa22998d0af2d404d45d29272340fe4df5ce7f2446670bfaa8c33ae52f708ec9ba8fcdce4db3abb7647632d1737e7d83f429e230d
+DIST jquery-rails-4.0.4.gem 343552 SHA256 bb03def077cbc4132aebcb331a14fc39f6a7fe4bb8b70df515b42bea46f14e0a SHA512 a14d3e30b5532dbea803d985d4e22c7ce762079f258b05f7123651d14ece912c91ac14a3d1a8d12d1d84ee7b21c145fcf355e3887cc5d0848aff83bccdb1485e WHIRLPOOL 30f45a78c4ff818ef493d148c50767694c31fdb40919a5b3d38eb120f31ac193d1ab14d99be0a3a451e95aa46ff38ac5330e1620fa8196ccf0feb8904b34fbcc
diff --git a/dev-ruby/jquery-rails/jquery-rails-3.1.3.ebuild b/dev-ruby/jquery-rails/jquery-rails-3.1.3.ebuild
new file mode 100644
index 000000000000..9979156b29bc
--- /dev/null
+++ b/dev-ruby/jquery-rails/jquery-rails-3.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+RUBY_FAKEGEM_GEMSPEC="jquery-rails.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="jQuery! For Rails! So great"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/railties-3.0:* <dev-ruby/railties-5.0:* >=dev-ruby/thor-0.14"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' jquery-rails.gemspec || die
+}
diff --git a/dev-ruby/jquery-rails/jquery-rails-4.0.4.ebuild b/dev-ruby/jquery-rails/jquery-rails-4.0.4.ebuild
new file mode 100644
index 000000000000..fc1519361d11
--- /dev/null
+++ b/dev-ruby/jquery-rails/jquery-rails-4.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md VERSIONS.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+RUBY_FAKEGEM_GEMSPEC="jquery-rails.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="jQuery! For Rails! So great"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/railties-4.2.0
+ >=dev-ruby/thor-0.14
+ dev-ruby/rails-dom-testing:1"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' jquery-rails.gemspec || die
+}
diff --git a/dev-ruby/jquery-rails/metadata.xml b/dev-ruby/jquery-rails/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/jquery-rails/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>