summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-03-09 07:47:33 +0100
committerHans de Graaff <graaff@gentoo.org>2020-03-09 07:47:33 +0100
commit0d3dbc2f7e733d104ed934ba20ec769bbfff28bc (patch)
tree21f05ab79a358917389951a8952e1d3161820307 /dev-ruby/kramdown
parentdev-ruby/bcrypt-ruby: add ruby27 (diff)
downloadgentoo-0d3dbc2f7e733d104ed934ba20ec769bbfff28bc.tar.gz
gentoo-0d3dbc2f7e733d104ed934ba20ec769bbfff28bc.tar.bz2
gentoo-0d3dbc2f7e733d104ed934ba20ec769bbfff28bc.zip
dev-ruby/kramdown: add 2.1.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/Manifest1
-rw-r--r--dev-ruby/kramdown/kramdown-1.17.0-r1.ebuild57
-rw-r--r--dev-ruby/kramdown/kramdown-2.1.0.ebuild51
3 files changed, 109 insertions, 0 deletions
diff --git a/dev-ruby/kramdown/Manifest b/dev-ruby/kramdown/Manifest
index b6f42f560b9b..3a6f83a6ab97 100644
--- a/dev-ruby/kramdown/Manifest
+++ b/dev-ruby/kramdown/Manifest
@@ -1 +1,2 @@
DIST kramdown-1.17.0.gem 260608 BLAKE2B 56f0abb2c94ab2de31bcd71940c22610efc8143c434295627513735b5983a369b0d9b36a88477a4e0b14bb23a3d314280702655c854cb7134e29bebc1f276966 SHA512 0f98f4234dec41b53d7f116be1075176c7fcbf21621c6f52a9e5b4055a777b01f1a0a912be81a651e85df022e7bab3ac183ee66cd87abeae092cd1920aceff04
+DIST kramdown-2.1.0.gem 119808 BLAKE2B a5beac52349fb49d315d83391d52574013bd76e084edb25a0b3bc0d813fc5b0dae0799a03bdd20fb500560effc94ad8f262fab9bbb8eef275aaead3405d3a64c SHA512 86a2934218365c71ff4f99591cba3b49ddc5ee60a78fcd7bf1f72e86281cda7bbea3c67b1b7caca6c4b8ca6e5b62d4df25e85089db659c93bd4da4b1c8eada69
diff --git a/dev-ruby/kramdown/kramdown-1.17.0-r1.ebuild b/dev-ruby/kramdown/kramdown-1.17.0-r1.ebuild
new file mode 100644
index 000000000000..d71602ca2c05
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-1.17.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
+HOMEPAGE="https://kramdown.gettalong.org/"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_rdepend "dev-ruby/prawn:2
+ >=dev-ruby/prawn-table-0.2.2 =dev-ruby/prawn-table-0.2*
+ >=dev-ruby/rouge-1.8
+ >=dev-ruby/itextomml-1.5
+ >=dev-ruby/coderay-1.0.0
+ >=dev-ruby/ritex-1.0
+ >=dev-ruby/stringex-1.5.1"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/minitest-5.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+
+ # Avoid tests requiring node to be installed with mathjaxnode or
+ # unpackaged katex.
+ rm -f test/testcases/span/math/{katex,mathjaxnode}* \
+ test/testcases/block/15_math/{katex,mathjaxnode}* || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}
diff --git a/dev-ruby/kramdown/kramdown-2.1.0.ebuild b/dev-ruby/kramdown/kramdown-2.1.0.ebuild
new file mode 100644
index 000000000000..ead8b978412c
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-2.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
+HOMEPAGE="https://kramdown.gettalong.org/"
+
+LICENSE="MIT"
+
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_rdepend "
+ >=dev-ruby/rouge-1.8
+ >=dev-ruby/stringex-1.5.1
+ !!<dev-ruby/kramdown-1.17.0-r1:0"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/minitest-5.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}