summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-21 07:04:06 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-21 07:15:04 +0200
commit4eb50551d1627eb437fae13c687f7333837e6f52 (patch)
treea9ed2de5826c90638ab1477c64c655ed764e858a /dev-ruby/kramdown
parentdev-ruby/pdf-inspector: add ruby25 (diff)
downloadgentoo-4eb50551d1627eb437fae13c687f7333837e6f52.tar.gz
gentoo-4eb50551d1627eb437fae13c687f7333837e6f52.tar.bz2
gentoo-4eb50551d1627eb437fae13c687f7333837e6f52.zip
dev-ruby/kramdown: add 1.16.2
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/Manifest1
-rw-r--r--dev-ruby/kramdown/kramdown-1.16.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/kramdown/Manifest b/dev-ruby/kramdown/Manifest
index 2344005f8d7f..885ea2af430e 100644
--- a/dev-ruby/kramdown/Manifest
+++ b/dev-ruby/kramdown/Manifest
@@ -1 +1,2 @@
DIST kramdown-1.14.0.gem 250368 BLAKE2B 78d3638ec58a5c237a9350cad1edabf2d4fa0307013a0ced18f6835c4a8cdd623e4825b06670d5c588147013b191912f93e51e74ab1fe007761c117334f378aa SHA512 bd6295db2fe0d3a7dca936d47f0aaf7f939a86361dfdd3203a52683a9eb11a68075cad7d068cc56a315db3c14e73cf5aebb87531ba3086301a7521c5a86f9905
+DIST kramdown-1.16.2.gem 258048 BLAKE2B a9b35b9e3882cafa32721d0555fa10d806973d4f6e7b617395c00acd3aee43552d74be2442411dc04fec48f7878a7459621ee7848365c165b51959e03a9451da SHA512 da6981969aca283c50b5a34650833c1364afcf74ecc64daba1eed20b198490bf1fdda91096f37574281b50f36713326c367307137446b1fd84a049358a13e4d7
diff --git a/dev-ruby/kramdown/kramdown-1.16.2.ebuild b/dev-ruby/kramdown/kramdown-1.16.2.ebuild
new file mode 100644
index 000000000000..6a4539198e65
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-1.16.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
+HOMEPAGE="https://kramdown.gettalong.org/"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_rdepend "dev-ruby/prawn:2
+ >=dev-ruby/prawn-table-0.2.2 =dev-ruby/prawn-table-0.2*
+ >=dev-ruby/rouge-1.8:*
+ >=dev-ruby/itextomml-1.5
+ >=dev-ruby/coderay-1.0.0
+ >=dev-ruby/ritex-1.0
+ >=dev-ruby/stringex-1.5.1"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/minitest-5.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+
+ # Avoid tests requiring node to be installed with mathjaxnode.
+ rm -f test/testcases/span/math/mathjaxnode* \
+ test/testcases/block/15_math/mathjaxnode* || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}